Fritzing does not work on macOS Mojave

It has been a while since last using Fritzing, and I was trying to open one of the files I saved almost 2 years ago.

I have updated my iMac to the latest Mojave release, and got strange errors.

I checked for updates, but it seems I have the latest 0.9.3b from June 2016.

Is Fritzing still supported? If so is there a later version?

No later version yet, but hopefully soon. Development stalled for a couple of years, but has now restarted with a new release scheduled soon (the first one will be minimal changes mostly to test the build mechanisms, but it may include a fix for this problem). See these issues on the github repo:

this one may be the issue you are seeing which in turn may make it in to the next release as a I believe a fix for it was merged, just not released.


I got it working by changing the user.
Unfortunately I still got errors:-

As suggested I deleted Fritzing and re-installed.

This produced further errors :-

When I again tried to update this repeated the first error above.

Sounds like you have database corruption. There are two directories (which hold your bins, parts in the mine parts bin and the parts database) in


on the Mac. They are not cleared during a reinstall to preserve your parts during an upgrade. The first thing I would try is make a copy of both directories for safety (Fritzing will recreate the directories if they are not there, and will access the old ones if they are replaced) and then try a database rebuild by starting Fritzing and select any window except Welcome (i.e. breadboard, schematic or pcb) and then click Part->Regenerate parts database. This will process for a while (regenerating the sql database) and then exit Fritzing. If the errors still occur when you restart Fritzing then delete the two directories (making sure you still have copies elsewhere) and then restart Fritzing. It will recreate both directories when it starts and should then do a parts update, which means it appears to hang for a while (for me it is usually a minute or so) while it clones the parts repository from github. Interrupting it at this point usually causes database corruption, so wait for it to complete and tell it OK when it wants to do a parts update to get the latest parts (as with the rebuild, it will process then exit Fritzing to complete the rebuild of the database). That should fix the parts database assuming you are not running in to the bug in the listing, but then you will need to reload your mine parts either from the saved directories or by loading the .fzz files and dragging the parts not in core from the temp parts bin that is loaded from the fzz file in to the mine parts bin (that is probably the easiest way, but copying from the saved directories will also work but is a bit more complex). The fzz files will as noted have any of the parts that were in the mine parts bin in the temp bin and should load as normal once the parts database is OK, so if you only want to access the sketches you shouldn’t need to recreate the mine parts bin if you don’t want to.


I tried this, but got an error:-

I assume the inability to open a temp file was the cause of the original problem with the update.

I don’t know where it is attempting to create this file.

In the beginning, I had problems on my iMac. This worked for me:

As mentioned, Fritzing creates a folder in Documents. Right-click it, ‘Get Info’ and set it to ‘Shared’.
I also created directories for MyParts (the Parts bin that shows up in Parts panel when creating/copying parts).