Fritzing 0.96 cannot save sketch on Mac OS Big Sur

Hi all, I’ve recently bought the 0.96 version but I cannot have it properly running on my Mac with Big Sur 11.4.
I can create a sketch but I cannot save it. I get the following error message:
Cannot write file temp:


/Users/itsme/.config/Fritzing/3b5afbcc9909c3f8ca7bb009761ff2a1/Untitled Sketch 2.fz

Permission denied.

I believe all permissions are properly set but, nevertheless, I’m stuck here.
Can anybody help?
Thank you

I am a linux user, not Mac, so things could be layed out different, but …

The path for the files being shown contains a guid, and that is in a folder in the configuration path. I would not expect Fritzing to save a sketch there. Perhaps the default save path is messed up. Or it could be a work area while saving. Try explicitly browsing to a folder before saving. And give the sketch a name, instead of leaving it as “Untitled Sketch «sequence number»”. Browse to something like Downloads, Desktop, Documents, etc.

Does that folder actually exist? If not, it is probably a temporary generated name used during the save. The actual sketch file normally ends with .fzz, which is a zip file containing the .fz seen in the error message, plus possibly other files depending on the parts in the sketch. If that IS a scratch area for saving, the missing permissions could be the ability to create a writeable folder in the /Users/itsme/.config/Fritzing folder.

Many thanks microMerlin.
Actually the .config folder was, for some unknown reason, completely empty, locked and only the System could have access to it, even if I had changed the permission, from a terminal window, a long time ago.
I had to redo it using Finder and now the sketch is saved without any problems.
What now bothers me is the fact that the Preferences command, in the Fritzing pulldown menu is grayed as if it were disabled. Where should be the preferences file?
Thank you again

Translating from linux experience, plus a FAQ wiki document, the preference file (for you) should be /Users/itsme/.config/Fritzing/Fritzing.conf. The FAQ says that Fritzing should recreate it on startup, if it does not exist. Assuming it has access to do so. On linux, that path would start with “/home” instead of “/Users”.

Goodmorning microMerlin,
the folder Fritzing exists into the .config folder, which is located as follows /Users/itsme/.config/Fritzing.
Inside the Fritzing folder I find three folders : backup, fizz and partfactory. None of them contains a preference file, as far as I can see. (unless it’s disguised under some weird name)
As I wrote, why the Preferences command, under Fritzing pulldown menu is grayed, i.e. disabled?

Fritzing.conf should be a file directly in the Fritzing folder. But that is based on linux not Mac information. I expect that the preferences is disabled in the menu because the file does not exist. I do not know why Fritzing did not automatically create it. Manually deleting that, and the Fritzing folder in documents (after backing up parts and sketches), is one of the standard suggestions to cleanup environment corruption. Both are supposed to get created fresh the next time the application is started. Assuming permissions are correct. There have been reports, mostly for older Fritzing versions, that some Anti-Virus programs can block Fritzing installation, but your environment seems to be well past that.

Hi microMerlin,
followed your suggestions. Deleted Fritzing folder inside Documents . Relaunched Fritzing app. The Fritzing folder has been recreated but Preferences is still grayed and, of course, there no preference file inside Fritzing folder. It’s a bit weird, isn’t it?

I found that an identical issue has been highlighted on GitHub at the beginning of June and nobody seems to have worked on solving it. The issue is still open.

This information is now outside of the Fritzing application, and being translated from linux, so check this with someone more of a Mac expert before making any changes to your system. For ‘permission’, check who is the owner of the folders in that path. If it matches linux, Users is owned by root, itsme, .config, and Fritzing are owned by itsme. To see that, from a terminal window

ls -dl /Users
ls -dl /Users/itsme/
ls -dl /Users/itsme/.config
ls -dl /Users/itsme/.config/Fritzing

On my system, editing to match your folder names, that would look something like.

drwxr-xr-x. 1 root  root     8 Mar 19 23:31 /Users
drwx------. 1 itsme itsme 1960 Jul  8 16:14 /Users/itsme
drwxr-xr-x. 1 itsme itsme 1522 Jun 20 15:35 /Users/itsme/.config
drwxr-xr-x. 1 itsme itsme   66 Mar 20 13:30 /Users/itsme/.config/Fritzing

After that, it is beyond my knowledge. The other report you found could indicate that it is a Fritzing bug (or bug in a library it calls) that only applies to Mac. I do not know how many others use that here.

General question to the forum. Is anyone here successfully using Fritzing 0.9.6 on Mac? Specifically with Big Sur 11.4? With access to Preferences from the menu?

The problem is the developers have not been able to reproduce the problem. For them the released version of 0.9.6 works on MacOS 11.4. It however sounds like there was an upgrade to MacOS 11.4 which may mean that the needed file was created and permitted correctly on a previous version of MacOS. It is possible that if you do this on MacOS 11.4 without previously having Fritzing installed it will not work (although I’m only guessing because I’m on Windows not a Mac!) The user directory clearing boilerplate message says the MacOS path should be


so try creating

~/.config/Fritzing/ Fritzing.conf

and see if it can be created (and if it can, if that fixes the problem.) If it fails, that may shed light on what is going on (permissions would be my first bet!). On Windows the config information is stored in the registry (which is a bug in my view, as it is not cleared with the user directories although I have never had that cause a problem so far!) If someone here has 0.9.6 working on MacOS 11.4 please share a

ls -l ~/.config/Fritzing

so we can see what a working config looks like (it is possible the location of Fritzing.conf has changed in 0.9.6!)


Goodmorning vanepp,
I created, without any permission problem, the Fritzing.conf (a plain, empty text file) under the .config/Fritzing directory on my Mac but it didn’t work. The file is there, the Preferences menu is stil grayed.
From a terminal window I get:
drwx------+ 5 root staff 160 7 Lug 20:38 /Users/itsme/.config
drwxr-xr-x 7 itsme staff 224 9 Lug 13:36 /Users/itsme/.config/Fritzing

Forgot this
-rw-r–r–@ 1 itsme staff 220 9 Lug 07:14 Fritzing.conf.
drwxr-xr-x 3 itsme staff 96 9 Lug 13:37 backup
drwxr-xr-x 3 itsme staff 96 9 Lug 13:37 fzz
drwxr-xr-x 4 itsme staff 128 9 Lug 13:37 partfactory

As written, the Fritzing.conf has been created today, as an empty txt file

That is too bad. I was hoping that would fix it. Either Fritzing.conf is being written somewhere else or there is something else wrong. @KjellM may be our best bet as he has a Mac 11.4 system that works and can see if this looks different in some way from the working system. We don’t so far have a working system to compare this to and so are groping in the dark (as is @KjellM who has the opposite problem, a working system that doesn’t show the error :slight_smile: )


In any case many thanks for the attempts. As I cannot see what is in the Preferences menu I don’t know what I’m missing and I guess I can live for a while without it. At last I can create a sketch, add parts and layout a circuit.
Hope that @KjellM will be able to provide some useful insights
Have a good day

You aren’t missing a whole lot (I don’t think I have changed anything except the codeview page in the 5 years I have been using Fritzing.) It would be good to get this corrected though as it is annoying. The problem has been not being able to reproduce it. Hopefully the listings from a not working system will tell Kjell something about where the issue is. Here are the pages from preferences with what can be changed:

this one applies to breadboard, schematic and pcb

and this sets the Arduino or Picaxe IDEs in the code page (I prefer to use the Arduino IDE external to Fritzing rather than the code pane)


Vanepp, you are very kind and I appreciate. I also agree on the fact that I’m not missing much. Usual preferences you set once and then forget.
Many thanks again

The topic of this post seems to have shifted somewhat. I can now reproduce the issue that preferences can not be opened. The main disadvantage is that you can not switch Fritzing to a different language as Peter explained. I don’t see how this is connected to the OP, who reported issues to save a sketch (see the title of this topic).

That was solved with the first reply :slight_smile: Which brought up the left over about the preferences, which was suspected to have a similar/related cause, generating debugging information and queries to trace some possible OS level interaction.

Thanks a lot for the clarification :slight_smile:

Good afternoon @KjellM, I see that you have succeeded in reproducing the “Preferences” issue. I understand that, here, we are a bit OT and I was wondering if there is a thread dedicated to this issue. Even if I wrote I can live without setting the <preferences I’m still curious to see if there is a solution.
Many thanks for you time and attention to this minor issue