Fritzing 0.9.3b "stopped working/responding"

Steps I took that resulted in the problem:

Just run the program and after program loads, Fritzing stops working.


Change compatibility mode to Windows 8…

My version of Fritzing and my operating system:

0.9.3(b 4.19) 64 on Windows 10 Pro x64

EDIT: Well, Fritzing updated some files and than I tried to run program w/o compatibility mode and now it looks it is working normaly.

I suspect you just didn’t wait long enough the first time. On first load Fritzing often appears hung when in fact it is just busy accessing github to update the parts bins.

Peter Van Epp

If Fritzing updated at the first start, why not show the dialogue about what is happening now? Let this be a modal dialog. It turns out that the user sees the environment, but it do not understand development environment to do anything or just hang.


That would be a good idea. However it appears to me (although I hope I’m wrong) that development has more or less stopped at this point and if we want things to change we are going to have to make the changes to the source and submit them and see if the developers respond. The source is available on github and when (or more correctly if ever :slight_smile: ) I manage to master parts creation I intend to go poking, but it hasn’t happened yet.

Whenever i start fritzing it stops please refer image

my windows configuration is
Processor: intel® Core™ i% CPU M520 @ 2.40 GHz 2.40GHz
32 bit orperating system
Windows 7 professional

Please help

Is this a new installation or was it previously working and now doesn’t? The first (and least destructive) thing I would try is reinstall the Fritzing program from the zip file as this looks like some piece of code may be corrupted. After you do that, you need to wait (for possibly quite a while) while the parts database gets updated, during this process Fritzing appears to hang but if you interrupt it, then the parts data base will get corrupted and you need to try the next thing (which is destructive so make sure you have a backup first if you have sketches in Friting!):

There are two user directories (with your parts and the parts database) which don’t get touched during an install (to not affect your sketchs during upgrades). On Windows they are in

c:\users\username\AppData\Fritzing\roaming\Fritzing (which is a hidden directory so you need to enable hidden directories in explorer) and

c:\Users\username\My Documents\Fritzing (where username is your windows id)

If you don’t have any parts or sketches you want to keep you can just delete those two directories and Fritzing will receate them, or you can move them aside by renaming them if you wan to keep something in them.


Hello Peter,

Thanks for your suggestion. It was earlier working and after sometime i am not able to open fritzing. I tried deleting the above folders you mentioned, i tried deleting fritzing and unzipping from .zip and opening fritzing.exe but still same observation please refer below.

This has the look of something corrupted in the core parts bin. There is a bug in Fritzing where if a part fails to load because it is corrupted Fritzing seg faults because it doesn’t check that the part loaded correctly and the seg fault causes the above message. That shouldn’t happen on a new install from the distribution zip file though as the parts database there is correct. I’d probably re download the zip file from the fritzing site if you haven’t already in case your local copy is corrupted. You will need to delete the two user directories before running Fritzing because it usually manages to store the corrupted part in the data base before crashing (which means it will try and load the part again on the next run).


Hello Vanepp, Thanks for the all your support. I think there was problem in my Windows may be some corruption. I have formatted the OS and now on fresh OS Fritzing is working absolutely fine. Thanks Again.