Fritzing 0.9.3b hangs and closes after a few seconds on OSX 10.7.5

Steps I took that resulted in the problem:

Dowloaded Fritzing0.9.3b.dmg from
Opened the dmg and dragged the Fritzing app to my applications folder
Started Fritzing app from my applications folder.
Fritzing starts downloading libraries and then comes up with the main screen.
Then after a few seconds the app closes and I get a msg from OSX saying that the app has stopped responding.

What I expected should have happened instead:

Fritzing to keep running.

My version of Fritzing and my operating system:

Fritzing 0.9.3b, Mac OSX 10.7.5

NB: I tried version 0.9.2b as well to check if that had the same problem. That version runs fine.

As noted in this thread I’m not a Mac user, and we don’t know if this person ever got it to work

However I’d suggest (assuming you don’t have any sketches or data) trying to delete or rename these two directories (from the parts file format doc here


and this hidden file


as corruption in one or the other of these has been known to cause problems on Windows. Note as well the comments on delay while loading new parts from github (there is currently an update pending so that will be happening) although that doesn’t sound like your problem. I’d also delete and reinstall you distribution directory however you do that on the Mac at the same time as deleting or moving aside the two user directories (which a reinstall will not affect which is why you need to clear them). If you solve the problem please report back so we know what to tell others!


Hi there, thanks for the suggestion!
I have deleted both folders as suggested and after that reinstalled the app.
(to be on the safe side I also downloaded the dmg from again and installed from the most recently downloaded .dmg)
Unfortunately the same issue still occurs.

The only other thing I can suggest is check your antivirus hasn’t decided that some part of the Frtizing download is a virus and isolated it (which might cause this) on Windows I’d have you check that everything in the zip file actually appeared in the Fritzing directory but I don’t know how to do that on a Mac. Hopefully one of our Mac users will have a suggestion.


Removed the app, the downloaded dmg file and the folders again. Then turned off my AV program and redownloaded the dmg.
After a new installation still the same issue unfortunately :frowning:

Some help from a Mac user would indeed be highly appreciated!

I fired up my old Macbook with 10.7.5 and installed Fritzing 0.9.3b to test this and I can confirm that I see the same behaviour. Looking at the log in Console I can see:

16/03/2017 22:50:53.781 [0x0-0x36036].org.fritzing.Fritzing: libpng warning: iCCP: known incorrect sRGB profile
16/03/2017 22:51:12.334 [0x0-0x36036].org.fritzing.Fritzing: dyld: lazy symbol binding failed: Symbol not found: _SSLCreateContext
16/03/2017 22:51:12.334 [0x0-0x36036].org.fritzing.Fritzing: Referenced from: /Applications/…/Frameworks/libgit2.23.dylib
16/03/2017 22:51:12.334 [0x0-0x36036].org.fritzing.Fritzing: Expected in: /System/Library/Frameworks/Security.framework/Versions/A/Security
16/03/2017 22:51:12.334 [0x0-0x36036].org.fritzing.Fritzing: dyld: Symbol not found: _SSLCreateContext
16/03/2017 22:51:12.334 [0x0-0x36036].org.fritzing.Fritzing: Referenced from: /Applications/…/Frameworks/libgit2.23.dylib
16/03/2017 22:51:12.334 [0x0-0x36036].org.fritzing.Fritzing: Expected in: /System/Library/Frameworks/Security.framework/Versions/A/Security
16/03/2017 22:51:21.155 ([0x0-0x36036].org.fritzing.Fritzing[923]) Job appears to have crashed: Trace/BPT trap: 5

Can’t help beyond that sorry :confused:

With the reminder I’m not a Mac person and so may be wrong, it looks like the ssl library on your machine is is either too old (if this is an older OS) or too new (which is less likely). In turn if ssl isn’t working then Fritzing won’t be able to connect to github to get parts updates and will likely hang. Is OSX 10.7.5 an older release (I’m guessing it is from the “I fired up my old Macbook” in which case there may not be a solution other than to upgrade the OS (if that is possible).


Thanks again for the replies!
Unfortunately it’s an older macbook I’m using as well, so I can’t upgrade the OS.
At the download it clearly states though that the requirements for Fritzing are OSX 10.7 and up.

Mac - OSX 10.7 and up, though 10.6 might work too

If the OS version is the culprit here, it might be an idea to change the requirements stated?
Still hoping there is a workaround for this though :wink:


Checking the crash report, the error seems to be:
Symbol not found: _SSLCreateContext

After some googling, it seems that that symbol wasn’t introduced until OSX 10.8

After some further digging around the web, it seems that on OSX the app uses the SecureTransport protocol instead of OpenSSL.
If there were a way to have it use OpenSSL over SecureTransport, that would fix this (or am I talking complete nonsense here? :stuck_out_tongue: )

I haven’t found a way to work around this. Does anyone have any ideas?


This post suggests that turning off networking before you start Fritzing might help? (Assuming the poster actually means v0.9.3b not 0.6.3b, but the post is from Oct 16 when 0.9.3b was the ‘latest’ version.)

It does work indeed when I turn off networking.

Which confirms that the issue lies in the connection to github.
Is there a way to do the parts update manually?


There should be a way, as the parts directory is a repository on github you should be able to download a copy, unzip it and copy it in to the

(this is on Windows your path will be different)

C:\fritzing\fritzing.0.9.3b.64.pc\fritzing-parts\core for the fpz files

C:\fritzing\fritzing.0.9.3b.64.pc\fritzing-parts\svg\core\ breadboard
icon pcb schematic (where the last four are directories under core). Note the weasel word “should” above because I haven’t had to do this. Hopefully someone with better knowledge will have a less manual solution but I think this should work and give you a current parts directory (although it may fail as it may not update the database correctly come to think of it). I’ve mostly done the opposite: swipe files out of here (such as the breadboard) to get at non exportable parts.
Please tell us if you make it work :slight_smile: