"For Production" Output

I probably have no chance in hell of fixing this the way FZ is at the moment, but I thought I’d ask.

I’ve tried PDF, SVG, Gerber and FZ 9.2 but where the pads are it leaves missing spots in the silk.

I know there is a bug when selecting single-sided in PCB view - it reverts back to DS on reopening -, but I tried SS and all silks are blank.

I think that is “working as designed”. It truncates the silk at the mask area around the pads to avoid the silk overwriting on to the area to be soldered. The only thing that could be possibly done about it is to move the silk back from the pads a bit but that would likely mean editing all the parts.


Ah, for DS PCB.

I wish SS would make silks, because this is SS.

I didn’t know that SS didn’t make silks, but I don’t think it would matter. As far as I know the idea is to not put silk ink on to the pad area where solder should go as it would block the solder so they truncate the silk at the copper area of the pad (or probably a little before) likely on both sides.


When tenting vias (covering with solder mask and silkscreen) you save a copy of your sketch and then go into PCB view routing menu and select all vias. Then in the edit menu select delete minus. Now when you export it you will not get the truncated silkscreens for the vias. A modified version of this technique should also work here. After making a copy of the sketch go in and make all the problem rings tiny enough that they do not truncate the silkscreens. Then use the silkscreen from this modified sketch not the original. It does mean having to make a modified version each time you make a new version but it is better than nothing.

The “select all vias/delete minus” only removed the vias and left the silk the same i.e. with gaps.

It seams that only ICs have a ring thickness option, and it’s mainly other parts doing it.

I suppose it’s not important because it’s just a few part outlines and not any values, but it’s a bit odd that SS silk doesn’t work at all.