Fixing Fritzing on Ubuntu 18.04


I tried to install Fritzing on Ubuntu 18.04, it failed! I figured out a workaround but I don’t see it written anywhere online in such a way that is clear and practical.

So, I understand that development on the javascript client/api is taking up all time now. And, at least for now, the desktop app of Fritzing is not actively developed. Therefor chances of this issue being resolved very soon are starting to look slim.

I started out by removing all Fritzing related files:

sudo apt purge fritzing*
sudo apt autoremove

Then I removed the config folder:

rm -rf ~/.config/Fritzing/

Next I reïnstalled Fritzing:

sudo apt update
sudo apt install fritzing

Starting the application normally resulted in the file /home/username/bins/core.fzb not being accessible.

Starting the application in terminal produced the following output:

$ Fritzing -f fritzing-parts
/usr/bin/Fritzing: 3: cd: can't cd to /usr/share/fritzing/parts
QIODevice::read (QFile, "/home/wouter/bins/core.fzb"): device not open
QIODevice::read (QFile, "/home/wouter/bins/contribParts.fzb"): device not open
QIODevice::read (QFile, "/home/wouter/bins/core.fzb"): device not open
QIODevice::read (QFile, "/home/wouter/bins/contribParts.fzb"): device not open

It is clear that the parts are simply not available. To fix this, we can download them seperately from github:

cd /usr/share/fritzing/
sudo git clone
sudo mv fritzing-parts/ parts

You can now start the app normally or via terminal by typing: Fritzing.

I hope this helps some people out who have trouble starting Fritzing on Ubuntu 18.04 because of missing parts.


Thanks for sharing, the sponsored download version on the site includes the parts but on Ubuntu the screen aspect ratio for this version seems set at ±120% so the parts are out of screen. Your workaround for installing the parts worked and apt version seems to set the correct screen aspect ratio.