Duplicate problem -- text misalignment?

In the schematic view.

Simply dragged in an SO8 generic IC.

Rotated it where I wanted.

Selected the part and CTL + D for duplicate.

Part1 was duplicated as Part2 but the (gray text) designating pin numbers and “SO08” is completely misaligned with the original Part2 text drops down and isn’t centered.

Also tried copy and paste with the same result. Any help ? – thanks

Damnit –
duplicate first the rotate.

Am I impatient or what?

This is a known problem - I posted it months ago -, that they’re looking at.

Even after you have fixed it - I go to the parts inspector and change the amount of pins and then change it back, ie 8 pins to 10 pins back to 8 pins -, after you close the project and reopen it, it seams to come back.

I just duplicated before rotating – that cleared it up. All is well but the “wire” (trace) manipulation.

Don’t care for that at all. – oh well

1 Like

No that doesn’t work.

Place IC in sch, duplicate, rotate both, save, and close. Now open it again.