Deleting duplicate parts bins?

I have many duplicate ‘core’ and ‘contrib’ parts bins on the vertical roster in ‘parts’ box. When I right click on them, the ‘delete bin’ function is lightened, so i’t’s not available. Did a search, but couldn’t find anything here on this- simple fix I hope.
I’m using V9.3b.32.pc
Jim

Not ‘simple’, but possible. I reported this as a bug recently.

Duplicate part bins

To fix, you need to manually edit the config file while Fritzing is shut down to remove the duplicate entries. The entries are all numbered, so make sure the final result is all in sequence. Renumber entries if needed.

The bug was reported against version 0.9.4, but I believe the config file is the same for the older version.

Can’t locate any ‘config’ files…
path??

The actual file will be named Fritzing.conf. The folder it is in varies depending what operating system you are using, and maybe on how you installed it. The FAQ page for issues about freezeup on start shows the folder paths. The second folder for each OS will be where Fritzing.conf is stored. As noted on that page, if you are using Windows, you will need to enable viewing hidden directories to get into the AppData folder from anywhere but the command line.

You COULD just delete that file, instead of editing it. Fritzing will recreate it when it does not exist, but that might loose other information in the file.

Again, I am assuming (and expecting) that version 0.9.3 acts the same as 0.9.4 for this.

Sometimes I had this problem…
I remove this from “regedit”…

Here, I wrote before,

I got it fixed, but I’m afraid to convey exactly what I did because I’m not sure-lol.
I went looking for the ‘show’ option for hidden files as suggested- instead found in that process the 2 main directories for fritzing on my WIN 10 tower.
So I copied both directories on a flash drive for safety, emptied the recycle bin and started deleting files and folders one at a time within those 2 directories that had either the word ‘part’ or ‘bin’ in title. Each time reloading fritzing to see the effect.

Located some files that, when deleted, would show the error ‘no parts located’ (or similar) when fritzing was restarted. This removed all bins in the parts group except duplicate ‘mine’ (which I found were easy to delete later w/ right click menu).

Miraculously, when I restored those files and restarted fritzing, all duplicate ‘core’ and ‘contrib’ bins were removed, and all missing bins were restored (sparkfun, arduino, etc)
Those of you more in the know are probably amused at my ‘trial & error’ method… Oh well, it worked :crazy_face:

That “change one thing” is a good technique when you do not know where the problem really is.

I have add to do that cleanup a few times now. The next time it happens to you, you might want to take extra time to make notes about what you changed, restored, deleted. So that the time after that, you can cut out the steps that did not help.

If I followed your description, you initially could not right click and delete the duplicate bin entries (the delete option was grey), but after some of the other experimental steps, the delete worked. Is that about right?

Yes, I should have documented- but plan on taking the other path of ‘don’t screw this up again’
I believe the duplicate bins happened while I was trying to left click grab & move parts bins up & down. The new position would show, but the old position was retained. Continuing this procedure made matters worse.
The right click menu to delete bins only works on the ‘mine’ bin. Procedure just went thru didn’t have any effect on the other bins, as they are all still greyed out.
Jim

Ah! The delete (that worked) was for parts in a bin, not for the bin itself.

The context menu shown from right click on a bin icon has a “Delete bin” entry, but it is grey, and not usable in my tests.

Good luck with the ‘don’t screw this up again’. I don’t believe I have every tried to reorder the bin list, but I see that I (again) have 3 copies of the WeMos, FRC, and DAGU bins. There is some other way of breaking this.

The right click menu to delete duplicate ‘mine’ bins was for the bin itself. When I right click my single ‘mine’ bin now, it is greyed out.
Right click on parts within a bin, the menu is different- doesn’t have ‘delete bin’ option.
Sounds like from what you are saying tho… Is that I will have to recreate my path

I never had a duplicate for “mine”, so did not see that case. The “delete bin” option was always grey for every bin.

If by “path” you mean the steps you used to clean up, then probably. I did not use any of what you described. I just edited the Fritzing.conf file using a text editor (not word processor), and deleted all of the duplicates in there. Plus changing the final entry number so that it stayed in sequence after I deleted the one before it.

I did not have actual duplicate bin files. Just multiple entries that were pointing to the same file.