Custom part not exporting to .fzpz

I made a custom part, all 3 views (Breadboard, Schematic, PCB) look and work fine in Fritzing but exporting as .fzpz is not working.

No error, or warning.

Any ideas?

Thank you.

More information needed:
What OS?
What Fritzing version?
Some details about how you tried to export the part.
Since you say it is working in Fritzing, I assume that it is already in your “my parts” bin

Welcome aboard. If you right click on the part in the mine parts bin and select “export part” it will export the .fzpz file.


Hello microMerlin,

OS: Windows 10
Fritzing version: 0.8.7
I tried to export the part by right clicking on the part in the MINE parts bin and select “Export Part…”

I’m happy to share the SVG files too.

As @vanepp said, that is the expected way to export. Version 0.8.7 is very old. I do not have an environment available with that to test. The current old version is 0.9.3b, with 0.9.4b available (since last year), and development on 0.9.5.

If you can collect and post the pieces, we can recreate the part, and see if there is something unusual in the way it is put together. For recent Fritzing versions, on WIndows, that should be a “.fzp” file in “My Documents/Fritzing/parts/user” plus matching “.svg” files in “My Documents/Fritzing/parts/svg/user/*/” (the “*” being separate folders for each Fritzing view, plus one for icon. Icon might not exist, often reusing the breadboard image). With that, we can at least see what you have available, and check if current versions work with it.

Have you got any other custom parts in “MINE”, that you loaded from fzpz files? Something downloaded from the Internet? Try exporting a different part. Load one from one of the “parts submit” posts here, save it to “MINE”, then try to export it again.

The question is whether it is that particular part that is a problem, or whether your version of Fritzing is failing to export parts altogether. Actually narrowed that down to failing to export custom parts.

1 Like

@microMerlin Thank you. I switched to v0.9.4 and it works now. Thank You.