Cursor icon BUG

Steps I took that resulted in the problem:

I reinstalled my PC so I buy the newest fritzing. My bug: the cursor changes after I move it above some component.

What I expected should have happened instead:

Just normal cursor as in previous version.

My version of Fritzing and my operating system:

Fritzing 1.0.0

Win 10 pro
I7 / GTX1050 / 32GB DDR4 / 2TB NVME gen3 3500/3500

Please help me I am not able to work with this.

Please also attach any files that help explaining this problem

Also this happens while I am moving components

A couple of suggestions. Try reinstalling Fritzing (as long as you don’t have any local parts I would also clear the user directories before reinsitalling.)

There are two user directories (with your parts and the parts database) which don’t get touched during an install (to not affect your sketches during upgrades). On Windows they are in

c:\users\username\AppData\Fritzing\roaming\Fritzing (which is a hidden directory so you need to enable hidden directories in explorer) and

c:\Users\username\My Documents\Fritzing (where username is your windows id)

If you don’t have any parts or sketches you want to keep you can just delete those two directories and Fritzing will recreate them, or you can move them aside by renaming them if you want to keep something in them.

also open an issue of github here:

which is the official bug reporting place. That said (although this is not 1.0 but a pre release version) I am not seeing a problem on Win10 pro (and thus the reinstalll suggestion)

for me it appears to be working normally.


You can find a workaround for the bug here:

Thank you, DPI scaling helps.
But I founded some another bugs.
Coordination system doesn’t work. I tried to place connectors in 20mm raster so I want to set the first connector to position 0,0 after I changed coordinates and pressed enter component moves to different place (as expected) but after I chose second component and give them coordinates 0,20 alignment doesn’t match after I choose first component coordinates wasn’t 0,0 there was random offset. I tried to zero it again but unsuccessfully.
I also tried to zero it manual with moving component and watching coordinates but after I unselect and select component again coordinates changes.

I found another bug with decimal numbers. Sometimes you have to use “.” and sometimes “,” for decimals. In case that “.” doesn’t work, I can apply “,” after pressing enter it looks like that decimal was not applied, hole diameter changes to round number but in the collapse menu (frequently used or history) you can find right values with dots and apply it correctly.

There is a video with bugs:

There is also few functions which should be implemented, where I should send these feedback?
• 4 and 6 layers
• Square PCB with rounded edges with settable radius
• Slot hole (defined by height and width)
• Square hole
• Option to remove soldering mask from wire / round (Higher currents tin enforced layer, Power BUS)
• SMD raster connector (same as 2.54 ribbon but without hole with settable pad dimension and spacing)

I cannot reproduce these bugs in Fritzin 1.0.0. Could you please open a bug in the bug tracker (Issues · fritzing/fritzing-app · GitHub) and state your operating system and language settings (Fritzing and OS)?
Regarding the lack of 4 and 6 layers, Fritzing focuses on beginners and simple designs. I do not think the feature of adding support for them is planned at this moment. You may consider KiCad, which provides more advanced features (at the cost of being a bit more difficult to learn).