Component search button missing

There is no search button in my Fritzing interface. There’s supposed to be a magnifying glass inside the area I have circled but there isn’t. I’m using the latest stable Fritzing.

Scroll the left hand scroll bar to the bottom of the pane and you will likely find the magnifying glass icon (search) there. You can then click on it and drag it up to the top of the screen where it usually is. If it isn’t at the bottom of the pane, post again (we did this for some time before only to discover that was the problem in the end with all of us feeling stupid :slight_smile: .)

Peter

Do you mean to use the buttons on the left of the panel on the right? I went all the way down the icons and there is no search button.

So it wasn’t at the top of the left Bin column when you use the up and down arrows on the column’s bottom. You might have to do a search, because I remember it somewhere.

The scroll bar on the left side of the panel on the right.

Looking back at the old posts (in the forum search bar type “search” to find them) clearing the user directories helped some users:

There are two user directories (with your parts and the parts database) which don’t get touched during an install (to not affect your sketchs during upgrades). On Windows they are in

c:\users\username\AppData\Fritzing\roaming\Fritzing (which is a hidden directory so you need to enable hidden directories in explorer) and

c:\Users\username\My Documents\Fritzing (where username is your windows id)

If you don’t have any parts or sketches you want to keep you can just delete those two directories and Fritzing will receate them, or you can move them aside by renaming them if you wan to keep something in them.

linux

~/Documents/Fritzing/parts
~/.config/Fritzing

Peter

I know I’m late to the game, but I had the same issue (on Ubuntu 20.04). I lost my search bar and “Mine” directories after updating my system. I was able to fix it pretty easily after poking around for a little bit, and figured this could help somebody else.

Go to ~/Documents/Fritzing/bins

In there, there should be 2 documents “my_parts.fzb” and “search.fzb”. Open those two documents. If they are blank (which was the case on my end), this is what is causing the problem.

To fix it, copy the code below into “my_parts.fzb”:

<?xml version="1.0" encoding="UTF-8"?>
<module fritzingVersion="0.4.3b.0.0" icon="Mine.png">
	<title>My Parts</title>
	<instances></instances>
</module>

Then copy the code below into “search.fzb”:

<?xml version="1.0" encoding="UTF-8"?>
<module fritzingVersion="0.4.3b.0.0" icon="Search.png">
	<title>Search</title>
	<instances></instances>
</module>

Save both .fzb files then start fritzing again. Both should be at the bottom of the list of bins, then you should be able to move them up.

Good Luck everyone!`