Can't see brd2svg converted part in Fritzing

I’m running on a Mac, OS X 10.11 (El Capitan). I’ve built brd2svg successfully with a couple of changes to the .pro file and the qmake command get it to build. I’m running Eagle 7.6.0 in “freeware” mode. I seem to have two problems:

  1. When I run brd2svg it starts OK and Eagle pops up in the background. It runs for a while but I get an error as shown below:

    $ ./brd2svg -e /Applications/EAGLE-7.6.0/ -w ~/Documents/Arduino/DollLights-BT/Fritzing/ -c contrib
    looking for all.packages.txt in “/Volumes/DroboM1/Projects/Fritzing/eagle2fritzing/brd2svg/all.packages.txt”
    “unable to finish adafruit tlc59711 v1.brd"
    QProcess: Destroyed while process (”/Applications/EAGLE-7.6.0/") is still running.
    parsing "adafruit tlc59711 v1.xml"
    generating params

    generating bin


Perhaps if I solve that one I can get the resulting part to import into Fritzing but that’s the second problems.

It does look like all the part files are created though.

The docs state that the parts files should go into ~/.config/Fritzing but I also find config files in ~/Documents/Fritzing … I’m not sure which is the right place. In any case, putting the parts folder into either place has no effect.

Any idea what I am doing wrong?

Bill W

I have gotten farther. I ran brd2xml.ulp manually from within Eagle 7.6.0. It correctly generated the .xml file. When I reran brd2svg it picked that up and regenerated the output apparently. Now I see the part! I need to assign a family apparently but it looks like it will work.

The correct place for the parts folder is in ~/Documents/Fritzing …

I am going to submit my updates that got brd2svg to build on my Mac. If I can figure out why the Eagle step building the xml file fails I’ll submit that also.