Can't get fritzing running on Mac at all

Steps I took that resulted in the problem:

It just freezes on startup.

Install was a bit weird: after mounting install image normally, copying to Applications took ~10 minutes. After all, it’s just 334MB…

I tried to download and install it twice.

What I expected should have happened instead:

My version of Fritzing and my operating system:

0.9.3b, El Capitan 10.11.5 (15F34)

PS The same version starts normally on my 10.10.4 (14E46) Yosemite.

have the same issue with windows 10. unzipping it took so long and it when i start it it freezes. i tried starting it with different compatibility setups, but no success.

Windows 10, 64 bit


The first start took a while, wait and observe the task manager.
Fritzing was running with 25% CPU usage for some time, then a update window appeared and i freez for some more minutes, after a second update and a restart of the software it finaly works!

All you have to do is wait… :slight_smile:

I’m not sure about MACs, but there is no progress bar on the download so it can look like it’s hung. Just let it sit for 15min.