Cannot select a library component

Hello, newbee here on this Forum!
I am already working a few months with fritzing 0.9.3 and have made some pcb’s with it.
Currently I am working on a new pcb and during the session suddenly I am no more able to
select any library component. Have not the foggiest idea what I did wrong. Did a restart of both the program and my computer system without any result.
My fritzing program run on a linux o.s. PCLinuxOS 64 bit
Can somebody on this Forum help me out please?

Hmmm, this is a new one. Likely answer is database corruption for some reason. Two things to try:

First take a copy of directories




as a backup (they contain all your current sketches). Then

  1. reinstall the Fritzing program from the zip file. This is unlikely to fix it, but is the least destructive (it doesn’t modify the two directories above).

If that doesn’t work

  1. Delete ~/Documents/Fritzing/ and ~/.config/Fritzing

Fritzing will recreate new copies of these when restarted. This will delete all your current custom parts and you will need to reload them by exporting them to fzpz files via parts export and then reloading them. You have likely hit database corruption somehow and this should clear that.


Well, I had to execute step 2 to get components dragged into my pcb again but I still have problems when I want to insert an extra wire. I usually drag the wire symbol from the breadboard view into the component pin which I want to do the extra connection and that worked up to that problem appeared. I can now again drag and drop components into my pcb and move them around.
But the strange thing is that when I click on any component there still appears that “forbidden” sign which I do now neglect.
I did a reinstall of fritzing but I use my synaptic package manager to get the program reinstalled.
Someone of our PCLinuxOS package people was so kind to install the latest fritzing version because it was not in our synaptic package library before.

I’m not really clear on the problem you are having, so if you could upload a copy of your sketch (7th icon from the left on the reply menu) I’ll have a look at it and see if I can see what i(if anything) is wrong. This may just be how Fritzing works. I generally install on Linux via the tar file on the distribution page, but as long as the package installs OK that should be fine (there have been problems in the past with some of the package installers that installing the tar files has fixed).

I’m not clear what this means, which is why a sketch would be useful. You are clicking on a component in pcb view when this happens?


EL84-Supply-80V.fzz (84.0 KB)

Yes, I am clicking on a component when that “forbidden sign” appears. I cannot show this via a printscreen because that sign does not appear on the resulting picture.
But perhaps if you open my pcb design and then click on a component perhaps you can reproduce this also.

For me both Windows and Linux (Ubuntu 18.04 lts) with Fritzing installed from the files on acts as expected. If I click on a part in pcb view it selects ( a dotted line around the edge to indicate it is selected, no forbidden symbol). I’d suggest moving the two user directories aside and downloading the bz2 file from the Fritzing site, and untar it and run Fritzing from there and see if it reacts the same. If it doesn’t then it is something in the install file isn’t correct somehow, if it does then somethere is something strange in your system.


This is the symbol I mean which pops up when I click on a component when I want to use it and it is called a “cancel”, or “right to cancel” symbol:

I followed your advise and installed the latest Fritzing version on my Linux Mint O.S.
Everything went well and guess what : also there pops-up that “right to cancel”
symbol when I click on a component. Perhaps this is the case on every linux o.s. and perhaps not on a Windows o.s. I am now having the feeling that it is not a problem at all. But perhaps I am wrong…

You see that when you are holding a part over the parts bin it came out of because it is telling you that it can not add that part to the bin you are hovering over since it already exists in that bin. If you move the part to the PCB/Schematic/Breadboard it goes away. If you try moving the part to a different bin the symbol goes away. It only shows up when you are trying to do something that it thinks you should not be doing.

Thank you sublimeartistry for you explanation. “Problem” solved!
I wasn’t aware of this because the last weeks I did not need any extra component.
Was only busy arranging/moving the existing components on my newly created pcb.
Must have completely overlooked this.