Cannot import any part file

Steps I took that resulted in the problem:

During the import process of a part, the part does not import and produces an error message ‘The system cannot find the file specified’. I have tried to import several parts from several sources, all failed with the same error message. It does not matter where I download the parts to on my PC, they all fail to import.

What I expected should have happened instead:

Parts can be imported.

My version of Fritzing and my operating system:

Windows 11

Please also attach any files that help explaining this problem

The first thing to check would be that you have write permissions to the path specified. The most likely answer is that it can’t write the file. Try writing a file to the specified directory (which should look like this, although this is Win10 not Win11)


Assuming you don’t now have any imported parts, clearing the user directories will cause Fritzing to recreate the needed directories which may fix the problem (although this hasn’t been a problem in recent years.)

There are two user directories (with your parts and the parts database) which don’t get touched during an install (to not affect your sketches during upgrades). On Windows they are in

c:\users\username\AppData\Fritzing\roaming\Fritzing (which is a hidden directory so you need to enable hidden directories in explorer) and

c:\Users\username\My Documents\Fritzing (where username is your windows id)

If you don’t have any parts or sketches you want to keep you can just delete those two directories and Fritzing will recreate them, or you can move them aside by renaming them if you want to keep something in them.