Cannot change pin labels on my parts

I am creating parts for my own SDIP package.

In Version 0.9.10, I had a problem where the pin labels in my parts in the schematic view would disappear every time I opened a sketch, but I was able to get it back by re-editing the pin labels.

After updating to Version 1.0.0, the pin labels no longer change from the pin number when they are edited.

Since it is a DIP package, I tried overwriting the my parts data with the Generic IC schematic image, but it still showed the pin number even after editing the pin label.

It works for normally for me. Your best bet is to upload the sketch (the .fzz file) that you are having trouble with so we can see the problem. To save the part between reloads you need to save the parts when prompted on exit.


This is the part that cannot be changed.
What is wrong?

test_sketch.fzz (19.1 KB)

There appears to be a bug in the generic IC. It is not saving the pin labels when stored in the bin (although it seems to never have worked as 0.9.3b does the same thing!) I guess I have never tried saving a pin label edited part before (I would normally export the generic IC and modify the resulting .fzpz file.)

so it doesn’t save the pin labels to the bin which is likely a bug, but as noted an old one.


Try changing the pin names of the SDIP components placed in test_sketch.fzz.
Previously, the pin names changed in the pin label editor were reflected in the schema view, but in Version 1.0.0, they are still shown as pin1, pin2, pin3.

Your best bet (at least until the bugs are fixed) is going to be to export the part as a .fzpz file and then edit the svgs in parts editor or manually (which is what I normally do anyway) to create a new part. You should remember to change the family to something other than “Generic IC” as well, to avoid letting Fritzing try to modify your new part in Inspector. I’ll probably poke at this a bit and create the needed bug reports on github.