Cable Designatoins in Fritzing

Hello. Is there a way to do “Connector and Interunit Cable Designations”?
Like in the attached image.

For now I’ll just have a dummy part with ‘W’ as the RefDes and a note of what the cable is.

Depending on the functionality you want, you can use plain text parts, or net labels. Text (dark blue) is just that. No meaning. It is just a label. Its only advantages are that it has no border, and it is resizable.

A net label (green) acts like the GND and VCC parts. This indicates an electrical path to all connectors (pins) that have the same label (net label part with the same text) attached. So in the case of wiring harnesses/multiple wire cables, you do not need to draw the actual wires.

For the sample, I just used a couple of headers, that I changed the labels (light blue) on to come closer to your example. More appropriate parts would come even closer.

This is great.

The objective is to document the type of cables I’m using. Colors, AWG, etc.

You need to be a bit careful to fill in the net label information. As shown, I think Fritzing will believe that all 4 of W9, W10, W11, W12 are shorted together. For a wiring connection diagram like this, it probable does not mater. But if you have more circuit connected in, the schematic will get real strange, real fast.

Defined connections can be traced in Fritzing by mouse down (and hold) on connector pin, wire end, or wire bend point. That highlights (in yellow) all of the pins, wire ends, wire bendpoints that are connected to the starting location. Doing that here will show all of the wires connected together. Unique net label parts can still be connected together by the wiring joining them, but they will not add that extra (no wire) connection between them when the labels are different.

Thanks, I’m also noticing my parts are not on the grid. I tried following the Inkscape tutorial but had scaling problems and ended up eyeballing it.

Assuming it is a custom part, if you upload the .fzpz file (upload is 7th icon from the left in the reply menu) I will have a look at what is wrong with it and tell you how to fix it. In Inkscape a Edit->select all then File->Document Properties->resize page to drawing is a good start. Setting units in the Document Properties page from px to in is also a good bet to avoid scaling problems.


@vanepp Thanks for you offer to help. I managed to fix.
I’ll give another shot to config Inkscape for easy part creation.