Bug: can't dismiss 'About' box

I clicked on the ‘About Fritzing’ menu item, and the about message window popped up, as expected. Unfortunately, there does not seem to be a way of dismissing the window, apart from terminating the application, using Command-Q (I am running on MacOS).

Normally, it should be possible to dismiss the About box by either pressing Escape or moving the focus outside of the window - e.g. using the mouse.

Fritzing 0.9.4 (beta!), running on MacOS 10.15.4 Catalina.

Please also attach any files that help explaining this problem

While I’m not familiar with Macs, if you click the x on the top right of the window that should dismiss the message (it does on Windows and Linux, and I expect the Mac will be the same.)

this is Windows, but the Qt ui is common across platforms (although it may not be the Mac way of doing things.) If this doesn’t work the best bet would be to open a bug report on github here:



Hi Vanepp,

Here is a screenshot of the About box that Fritzing displays - it appears on an entirely black screen, with no ‘Close’ option.

See net post for second image :frowning:

(19 seconds later)…)

For comparison, here is the About box produce by the Safari browser - the ‘Close’ button on MacOS is represented by the red dot in the top left corner.

Screenshot 2020-05-05 at 18.02.54

Based on this, I’ll open a bug report, as you suggest.

I have one environment where the close button is not visible, but is actually still there. Try clicking where the button should be and see what happens.

Hmmm, I start-up up Fritzing again and selected the About option - and it worked perfectly. Red/Amber and Green buttons - and pressing the red button closed the dialog. Which is what it should do.


  • An amber button makes no sense, since this is equivalent to the Windows ‘Minimise’ option. This just minimises the dialog into the Dock area, while leaving the Window in existence, I can re-open the window and then close it properly, but this should be unnecessary,

  • For completeness I also pressed the green (Maximise) button. Curiously, this led to exactly the scenario that I was complaining about - i.e. the dialog appears alone on a black background, with no border and no red/amber/green buttons. I tried following your suggestion by clicking where the ‘red’ button ought to be but nothing happened.

So, it may be that the About box is being created in a Maximised state?