All sketches on network empty

Didn’t use fritzing for a while.

Whenb i want to open one of my recent sketches the sketch is empty.

Location of my sketches are a samba share on a linux server.

However when i copy a sketch to one of my local drives the sketch is ok.

In the past i did never had a problem with this.

A while a go i change the shortcut to run in administrator modus.
Administrator modus is unchecked now.

But i still see blu/yellow shield on icon.

How do i fix this?

If you move one of the sketches on the samba share to the fritzing local disk then fritzing will read it, is that correct? If so then you likely have a permission problem on the share which you need to correct (perhaps by setting administrator mode again on the short cut). Someone recently had a similar problem because they had installed fritzing as administrator (on Windows). In that case uninstalling Fritzing and reinstalling as the user rather than administrator fixed the problem. While I’m not sure what OS you are on, try doing a directory (dir in windows, ls on linux or a Mac) of the share and see if you can see the files on the share as the user fritzing is running as. If you can’t you likely have found your problem.


iI use windows 10.

I already copied the fritzing.exe to fritzing2.exe.
When i use last-mentioned it’s no problem.

I right-clicked the fritzing.exe file but what i try i cannot rid of this run-as-administator flag.

Then I’d probably delete and reinstall the fritzing app from the zip file and see if that works better. I suspect that you are seeing a permissions problem blocking fritzing from accessing the share, but I’m not sure how to fix it (I don’t use samba and am on Win7 here).


Tried that and just as the cat the yellow/blue shield came back.

It’s just the path to the exe file. Must be somewhere in the register.

I can change the path or rename the exe file though, but it is not really fixing the problem.

Do i hate Microsoft …

I’m not sure what the yellow/blue shield is (I haven’t seen it on win7, but I don’t have smb enabled at all so that may be why). The path the the exe should be in the short cut properties (right click on the fritzing short cut and select propeties at the bottom it that still works on Win10 (I don’;t run 10 either for exactly this reason :slight_smile: ). Mine says Target: C:\fritzing\fritzing.0.9.3b.64.pc\Fritzing.exe. You might also try deleting the shortcut and recreating it (as a reinstall won’t do that). The other thing to maybe try is deleting the user directories (which also don’t get touched in a reinstall) but you need to save all your sketches first. Come to thing of it you must have sym links (or whatever Windows calls them) to your samba share (I do something similar to move the directories off the system disk), deleting and recreating those may be a good bet.

Amen brother :slight_smile: . Although I have a backup image of Win10 for all my machines, when Win7 support dies I think I’m going to change to linux rather than win10.


I already tried with shortcut properties, checking rus as adminstrator on and off.

Does not help.

Even the exe file had the b/y shield in the c:proram files(x86)\Fritzing

So i copied the fritzing.exe to fritzing2.exe so i have 2 versions.

The sketches are on a linux server (samba) mounted to H:
Did right-click refer to the fritzing2.exe program.

So now i have 2 fritzing in the context menu.

Just like the Beatles, I … Let it be, let it be

I think i let it be.

This pretty much has to be a Windows weirdness :slight_smile: somehow Windows has attached something bad to the fritzing.exe file name that survives deleting the file. If you have something that works for you I agree, let it be and curse Microsoft :slight_smile: .


Made a copy of fritzing.exe to fritzing1.exe (now have 3 versions).

Searched the register for fritzing.exe. One key had value ~RUNASADMIN
renamed it to fritzing1.exe

Now the original file is working however keeps the yellow/blue flag.

I could now clean the register of al fritzing1.exe and fritzing2.exe entries and remove the same files …

The ugly thought just occurred to me that you may run in to trouble with the Fritzing database and sketch directories (and possibly temp files) that may have and/or need administrator permissions to be read or write which may still break Fritzing. If so you will need to preserve your sketches and delete the two directories. I have instructions for doing so on a normal installation which may help you identify what you need to delete if this happens. With luck it won’t become an issue …