555 IC Will not align with pins in center of Breadboard

Help!

I just downloaded the latest version 0.9.3, for my MacBook Pro, and I can’t get a 555 IC to align with the
center pins of my breadboard. I first created a simple schematic of an LED flasher using this IC.

I also tried a new project and started with the breadboard first and tried adding a 555 IC and still couldn’t
get it to align with the center pins. I’m selecting a dil-8 packaging.

So, I can’t progress if I can’t get a simple IC to align. Can anybody help?

Thanks,
Gary

While I’m on Windows rather than a Mac, are you using the 555 from core parts? If I do that on win it aligns fine. Note sometimes (due to a fritzing bug I think) you have to move the part before it will snap to the grid correctly so you might try that. As well in the view menu make sure “align to grid” is set and grid size is .1 (I think they should both be default but perhaps not, or perhaps they have been changed). If none of that works post the fzz file of your sketch here and one of us will take a look at it and see if we can see the problem.

Peter

Peter,

Thanks for your quick response.

I’m doing a search for the 555 and using one with a dil-08 type.
Should I use one from the “Core” components?

My grid size is defaulting to 0.1 . I changed it to 0.07 and it worked!
Maybe it’s suppose to work with a 0.1 setting but I’ll take the 0.07 as long as it will
let me move forward in the learning curve!

Thanks,

Gary

Hmm, that should be the same 555 I used in core which seems to be the correct part spacing (some of the user generated parts have either offset from the grid or have incorrect spacing issues but most that you find in the parts bin are pretty good). Is your grid perhaps in mm rather than in in the view set grid size window (although that doesn’t work out either …)? If you would save the sketch then upload the resulting fzz file (7th button from the left on the tool bar at the top of the reply window) we can have a look at the parts and see if we can see a problem.
Perhaps one of our Mac users can provide illumination, but I think this is the first case like this that I have heard of. However if .07 is working thats good :slight_smile:

Peter

Peter,

I started a new project, with the grid setting at 0.1, and it worked. I don’t know why it’s working now
while it didn’t work on the the first project that I started. I didn’t do anything differently.

I can’t get the wire jumpers to form 90 degree bends. The bends are either less than or greater than
90 degrees. Do you have any suggestions for this problem?

Thanks,

Gary

That sounds like a grid problem again, but I don’t know why. A work around may be to set the grid size to .01 and see if that will let you get close enough to 90 degrees to work. Hopefully someone else may have a better suggestion. Sometimes (again on Windows anyway) the initial component placement is off the grid, in that case if you move the component with the mouse it will snap to the grid correctly. That can cause the wires to not bend correctly as they are snapping to the grid.

Peter

Since it sounds like you are just starting with Fritzing and won’t have any custom parts etc I would suggest purging everything that has to do with Fritzing and do a fresh install. You will have to manually find and delete the hidden Fritzing folder that contains you profile and settings etc.

Clearing and reinstalling is probably a good bet. The user files (that won’t be touched on a reinstall) should be in

/Users/username/Documents/Fritzing/parts
~/.config/Fritzing

on a Mac (where I expect “username” is your login name). I think something wrong in ~/.config/Fritzing is the most likely but doing all of them is the best bet.

Peter

Just thought I would add on Linux the hidden config files are in the same place as on a Mac. home/.config/Fritzing

Thanks Peter and sublimeartlistry,

I removed all the Fritzing files including the hidden Fritzing folder and reinstalled the latest version
of Fritzing.

All components are aligning exactly now on the breadboard! Also, any and all wiring can be bent easily into a 90 degree angles.

So, thanks for your suggestions and help. I’m moving forward from here!

Thanks,

Gary

Thanks for your help!
Everything is working great now.

Gary

Glad to hear it is working for you now.

Good call on deleting the databases I should have thought of that at the start :slight_smile:

Peter