4 Component files missing on Start-Up

I had to do 5 installations before I could get Fritzing to work. Before the 5th installation I stopped my AV and update Windows. Size of downloaded zip file is 186 786KB.
When I start Fritzing, I get a message that the following 4 files are missing:
‘mystery_part_sip_3_100mil’ at ‘mystery_part_3_.fzp’
‘generic_ic_dip_8_300mil’ at ‘generic_ic_dip_8_300mil.fzp’
‘generic_female_pin_header_2_100mil’ at ‘generic_female_pin_header_2_100mil.fzp’
‘generic_shrouded_pin_header_10_100mil’ at ‘generic_shrouded_pin_header_10_100mil.fzp’

I have done the Fritzing Update, but before that I had to perform another function because there were component files that were replaced or altered.
System: Win10 Prof - upgraded from Win 7. System is up to date.

Plenty of space, memory and speed.

The likely answer is a corrupted parts data base. I’d try deleting the parts data bases (a install won’t touch them) and retry. Note that it will connect to github and update that parts database, and if you interrupt that it will often corrupt the parts database. Note this will delete any parts or sketches that you have so make a copy of them or the directories before
trying this.

There are two user directories (with your parts and the parts database) which don’t get touched during an install (to not affect your sketchs during upgrades). On Windows they are in

c:\users\username\AppData\Fritzing\roaming\Fritzing (which is a hidden directory so you need to enable hidden directories in explorer) and

c:\Users\username\My Documents\Fritzing (where username is your windows id)

If you don’t have any parts or sketches you want to keep you can just delete those two directories and Fritzing will receate them, or you can move them aside by renaming them if you wan to keep something in them.


Thank you. I’ve done as you described, but still get the same result on opening Fritzing.
I have, however found that the message only comes up when I do not run the app as “Administrator”. Also, when I run it as “Admin”, I get the splash which asks if I want to allow the program to make changes to my computer. The program is therefor not installed, but runs from the .exe every time.
Thanks for the help.


Delete all your fritzing related stuff. The destination folder, under my document there is a fritzing folder to. Delette the downloaded zip too. If you can remove it from registery. Download it again and put it like in c:/fritzing/ . I saved lot of trouble puting it here and be sure once the program is unziped to verify that the folder is not read only . there is no installer

I agree with 25pinjo15 's advise. You don’t need (or probably want) administrator privs to install Fritzing it is intended to be installed as the user. So delete all the files in the fritzing install director and the two user directories (and maybe the zip file, but I don’t think that should matter as long as it is readable) and reinstall Fritzing on you user id without admin privs. As he said it doesn’t have an installer but always runs from the .exe file and needs to be able to update the parts data base as your standard user ID. If it can’t or needs higher privs to do that it will likely break.


I did as both of you suggested and it WORKED!!! The REGEDIT was a bit stressful though. Thank you so much.
For other newbies may I say that at first I had my Fritzing folder with the extracted folder in my “D” drive. Not C. I moved it to “C”.
When I extracted, I used 7-Zip (please do not see this as an advert. I have no connection and read about the extractor while trying to find a solution).
I the ran the .exe file as an ordinary user - not Administator.
I also created a shortcut on the desktop, renamed it and it works great.

As a first project I designed an Opto Coupler PCB using a IL612-2 for the USB on my function gen. Very simple and small.

Thanks again

1 Like

your’e welcome .

and have a nice creating session (sorry for bad expression canadian french here)