Is there a bug in 0.9.3b?


#1

Having just purchased a new computer I had to re-install the version that I last installed on my old PC, but it said that there was a new version, so I downloaded and installed the new version.
when I run this version it reports ‘program not responding’ when ever I try to click on a menu item. the only way I can kill the program is to go to the task manager.
I tried re-downloading, just incase it had become corupted, but this did not work either. Went to website and noticed that there was a 64 bit version (the previous version I ran was 32 bit).
When I installed this it also did not work. I also tried running in compatibility mode Windows 7, still did not work.
The only version that works is the previous version: 0.9.2a 32 bit.
My PC spec:
Windows 10
Intel i7-6700 CPU
8Gb memory
Has anybody experienced this problem.
Are Fritzing doing anything about it?


#2

I’m experiencing the same problem here at my PC.
Windows 10 X64
Athlon FX8150
32GB DDR3
More details available on request of course.


#3

How long did you leave it before giving up?

I ask because when I installed 0.9.3 it seemed to take ages to start-up for the first time, displaying the circling cursor and ‘program not responding’.
I gave up a couple of times and killed the program before I ended up getting distracted by something else happening and left it long enough to go through its silent start-up machinations.
The second and subsequent times I started the program it was responding almost immediately after the splash screen had disappeared.


#4

I’m also experiencing start-up issues (Windows 10 Pro V1511, 64bit, I7-3930K 3.20GHz, 16Gb RAM, installed Fritzing this morning), though in my case the app starts up OK, but soon hangs.

The first time I started it up, I let it sit for quite a while and it eventually opened a query window about needing to remove some obsolete files in order to update. When I clicked.OK, Windows reported “not responding” and offered me the option to wait or close it (I closed it).

Subsequent start attempts brings up the main “Breadboard view” window, but the revolving hourglass icon seems to go on forever. Clicking on the Frtzing window yields “not responding”…


#5

It downloads a lot of stuff first time and I remember my Win7 saying it’s not responding, but I just waited and it worked fine after it finished.


#6

I’m experiencing the same “not responding”/lock up problems as blubluh on my new Win10 (build 1511, 16GB RAM, 64-bit OS)… I had no problems on my previous computer (64-bit Win7).

Since this problem is occurring on multiple systems, I hope we can all agree this is a issue which needs attention. What can we do to assist in finding a solution?


#7

After a few tries, it eventually installed and updated for me. The key is waiting quite a while for it to perform who-know-what in complete “silence” such that it appears to hang even though it is quite busy.

I would suggest that some sort of progress display be added to assure the uninitiated that all is well.

Cheers.


Can't run Fritzing on windows 10
#8

I see what you mean! I guess I’m too impatient!
The problem is that they do not use an installation program, where all of that sort of updating and cleaning up files can be be done before first use. I’t’s not that revolutionary to do things that way.


#9

Thanks a lot, he is right, Fritzing fixes the files on its folder and then updates, Thank you clarachdave!


#10

You have to wait till response.


#11

The likely answer is that you didn’t wait long enough for the parts update to complete and now the parts data base is corrupted needs to be cleared. There are also a number of problems with patch levels on Windows 10. If you search the forum for Win10 and/or dll you will likely find a solution. As noted you likely need to clear the user directories (which don’t get touched during an install or reinstall) and be patient on first access as it downloads parts updates from github.

Peter


#13

Not ready to use. I know it’s free and I appreciate that. Why can’t we just import a .fzpz that can land in the “My Parts” lib?


#14

You can. In the top right corner of the parts menu there is a hamburger icon that opens a menu with an import function.


#15

Or click file->open, browse to the fzpz file and click on it. Assuming it is a valid part it will load in to the my parts bin ready for use. If it is an invalid part, a Fritzing bug will cause a hang and require the parts database and all your sketches to be cleared (so it is a good idea to keep a backup of the two user directories before loading unknown parts).

Peter