Ground Fill - Still need traces?


#1

I am attempting to use the Ground Fill. I have seeded my ground connections. My question is… once I have seeded them and applied the ground fill can I remove the traces that connect my grounded pins? If I attempt to do this the dotted wire line reappears as if there is no connection among all of the ground connections.


#2

Can you please provide an example?


#3

Here it shows the GND trace (red line). on C8, C11, and C1 (and on the other caps as well) I have set the ground seed for them.

Second image will be put in another post because it won’t allow me to put two images in one post.


#4

The rat nest lines still show after applying the ground fill. Am I doing something wrong?


#5

I would love to have the above question answered too. In the second picture, if you do autorouting then despite the ground connection already connected to ground plane it will autoroute them with their own connections. I know that I can work around by not using autorouter, or remove the connections afterward, but isn’t there a solution for such case? Thank you.


#6

@tcox8 When using Ground Fill Seeds you don’t connect them with a trace. The ratsnest lines will still appear to show the ground pins and connections even after ground fill. To remove the ratsnest; Click on the top menu View, then third from the bottom uncheck Ratsnest Layer.

Never use auto rout… but if you must, manual connect the main pins first (5v, 3.3v, etc.) and then use auto rout.


#7

Ok, got it. No autorouter. Run traces manually, then ground fill, then remove ratnests.


#8

That is it… you got it…


#9

Thanks steelgoose for the info!