Troubles with new install on Mac

Steps I took that resulted in the problem:

Started the software and got the error message that some files were unable to find.

I cannot open example drawings or re-open saved files.

What I expected should have happened instead:

Opening without errors, seeing an example drawing, being able to re-open and edit a saved file

My version of Fritzing and my operating system:

It is a new install with the latest version.
I am working on a macbook pro with MacOs 10.12.6

I have already been searching for similar posts on the forum, but can not seem to find one with a solution. I have installed and am using the software as the same user.

Thanks in advance for your help. I would like to get this to work because it is the best software that I can find for my needs. Really want to get started :smiley:

Because they are all parts, maybe you interrupted the part update - there is no progress bar to tell you it’s uploading -.

I think you have to delete some folders, but we will have to wait for Superuser Vanepp. :slight_smile: for instructions

Old_Grey is likely correct that the parts database is corrupted. On a Mac
it looks like you need to delete

/Users/username/Documents/Fritzing/ (where username is your login id)

On restart Fritzing will recreate both directories and then spend some time updating the parts database from github. It is important to let that finish so the database doesn’t get corrupted. It often appears that Fritzing has hung and people quit it which corrupts the database and causes this problem.


Thanks for your answer.

I have tried that, but got an error stating that I needed to regenerate the parts database. When I tried to do that, I got an error “unable to create temporary file”.

When I was looking into this on the forum, I have seen screenshots of other users and they seem to have much more folders and files in there. I seem to be missing some files… I have already tried to delete everything, re-download and re-install, but with no luck…

There is a known issue on macs where it won’t allow the parts to update because of how it creates the temp file in the wrong location. The good news is it has been fixed in the github head and will be part of the next release and in the mean time to work around the bug you need to start fritzing from the command line and that will allow the update to complete. Then you can start the normal way until another parts update and again at that point start it from the command line.

Edit: You may need to delete the hidden files again if the broken update has corrupted the database already.

Thanks again for all the help @sublimeartistry @vanepp @Old_Grey !!!

Like already stated in the thread, not pretty but works for me.

Any idea when there will be a permanent fix and update ?