TP4056 Charger board

The pads on the pcb supplied are set to a hole size of .038 in which fits the .1 headers so if you move the pads to the correct places and change silkscreen if you want to, you should be good. I need to poke more at why changing the font family didn’t fix breadboard but I haven’t yet.

edit: A replacement part where breadboard has correct text. I had to remove all translates, and then all the tspan text and pxs from font-size to get here and I’m still not sure why, but this is at least better and I have broken and fixed files to ponder …

tp4056.fzpz (12.0 KB)


1 Like

Hi Peter,

Fritzing is not letting me load your new part as it is saying it is already loaded. I tried renaming the file, but it seems to be using an internal ID.

Thanks for your help.


You have to delete the old part from

Thanks Old Grey but I have tried that and Fritzing is still saying there is a part loaded with the same name. So quite where it is hiding I don’t know.

I’m not sure but the problem appears to be that the name of ID is the same as the Battery Holder Peter did earlier, and that is in My Parts. While I have moved it out of the folder User, it still is in Fritzing somewhere as it is still showing in My Parts. I can’t edit it, but I can use it still.

Managed to do it. I have tried to edit the pcb SVG in Inkscape, by downloading it and editing it, but then when I resave it all the layers seem to have moved around. So it would not reload. This is the SVG I have redone and moved the pads and labels around. I had to resize the board as that was wrong, but now should be correct. As I said earlier the pad spacing on the right are 2.54 mm and not 3mm which would be more correct for the actual board. However I am using the part to place the holes on my pcb and the attachment will be by pin headers.

The correct way to remove a part is remove it from the bin inside FZ, otherwise you have to search and chase instance inside the file system.

Yeah you didn’t follow the FZ layer rules for PCBs. Go watch my PCB video if this doesn’t make sense.

You make a group called silkscreen and put all lines and text in it.
Make a group below that called copper1(top copper), and in that make copper0(bottom copper), and in that put all contacts. With round contacts the OD is the size of the pad, and the ID is the size of the hole.

If this part will be fitted to a custom PCB that you are making, make the header pins 3mm apart and just install individual pins in each hole.

Many thanks for that. It’s starting to make sense. I think I have the right layers, but when I change one layer it seems to change others, so seem to have got myself in a right muddle. Could someone look at this SVG and see what I have done?

Thanks for that Old_Grey, but somehow the connectors seem to have stayed where they were and not moved with the copper layer. Not sure what layer they are on? Here is an image of what comes up when I load the part. Any ideas?

Mine is fine except for the fonts. You have to xml edit it and remove the px in the text sections.

Put a a 6pin header on the PCB and Edit it and add the svg and save as a new part.

I managed to get the connections sorted but the fonts suddenly went really small. Also I added the part initially to the top layer of my pcb, then rotated it 180 degrees and moved it to the other side. The connections all moved correctly but the copper pads stayed where they were, so I ended up with two lots of pads.

Mine is fine, try this one.

Generic female header - 6 pins.fzpz (5.2 KB)

Not sure what you mean by removing the PX. For instance the Style for OUT + is showing,


How do I change that to make the font bigger?

Your one worked sort of. Top view it loaded properly. Then I rotated it 180 degrees and moved it to the bottom at which point it reverted back to a 6 pin generic header. :slight_smile: So I tried it by moving my view to bottom and then added the board. It worked no problem and didn’t have to rotate it. Why it is doing what it is doing is beyond me, but for now it’s working. :smile:

See the px
Remove the px

The part above has been fixed for fonts and works fine. You can get the svg out of that if you need it.

Tried that and it won’t let me save it like that. It automatically put the px back when I pressed Set.

You can’t do that in INK, you need to do it in WordPad. XML edit it

It doesn’t matter now I’ve put it in Peter’s part.
Here it is - TP4056-2.fzpz (11.6 KB)


Finally got there with your much needed help. I think I need to stop trying to design my project and start playing with Ink. That way I might get to work it a bit better. I know how to work Corel Draw better, but no matter what I do I can’t get draw to do what I want it to do and it keeps adding stuff in XML I don’t have a clue what it is. Computers will be the death of me yet. :smile:

Use whatever vector package you like, we only use INK because it free.

I know my instructional vids will take half a day to watch, but you will save 10x as many hours than fumbling around. I don’t do any computer stuff these days without spending days watching tutorial videos because everything is complicated. Even similar programs have their own individual foibles so knowing one won’t help you with another. I would’ve spent 10hrs each on FZ, KiCad, Altium, and Eagle before I decided to go with FZ.

As Old_Grey said we use Inkscape because its free (and in my case because being free, its the most likely thing for other people to be using, so knowing its quirks is helpful). Corel Draw works fine, in many ways better than Inkscape I think. I’m working on a python script that will remove the px from font size and do a variety of other things that Inkscape does that Fritzing doesn’t like but it isn’t quite ready for release yet.