Part not meeting

Hi all, am trying to use a Part, a Conductive button from the sparkfun library, but the copper doesn’t meet on the pcb connections, its noted as a working part so im wondering if there is something in my settings?.

I have tried enlarging the element in the SVG that the track connects too
but it still doesn’t meet. Anyone have any advice? Thanks in advance.

So i managed to make it work, so it connects (a bit rough)

But im getting all these errors (including the original part unconnected) is this an issue?

Excuse the extra posts, can only do one image at a time

You are likely seeing this Fritzing bug:

which isn’t fixed yet. I assume you added the square pads external to the part, if so that is what is causing the DRC errors. If you add the square pad to the copper layer of the pcb svg so it is part of the part the drc error should go away. If you post the .fzz file above (upload is the 7th icon from the left in the reply menu) one of us can have a look and find you a solution. A narrower trace than the wide one should also fiz the problem without needing the square pad should also fix the problem.