Ground Fill not working after deleted and restored

Hi folks, new to Fritzing here.

I’ve developed a PCB and want to use the Ground Fill option to reduce the amount of etchant required to etch my own board.

I did it once in the beginning to try it out and it worked fine. Because I needed to do more work on the design I manually deleted all the ground fill objects, and finished it. Now, when I attempt to re-do the Ground Fill, it take a number of attempts to fill all the spaces on the board, and the traces that have ground fill seeds don’t connect to the ground fill anymore. :frowning:

I would REALLY hate to have to do this over again as I’ve come up with a design that works (took many hours), is there a way to reset the ground fill seeds and the function so it will both fill the open spaces on the board AND connect all the grounds like it is supposed to?



Make sure you are selecting ground fill not copper fill. Also the space between that is filled is controlled by “set ground fill keepout” in the routing/copper fill menu.

You can also clear all the seeds in the routing menu.

I have also heard there is a bug that makes ground/copper fill not work correct if nothing has been clicked or moved since opening/saving the file.

Dude, thank you so much! :smiley: I was using copper fill and not Ground Fill (Thought they were the same).

I just cleared the copper and redid the Ground Fill command and it worked perfectly. I also increased the space around the traces which will hopefully make it a little easier to do the soldering without bridging any traces.

Glad I could help. :slight_smile: