Fritzing 64Bit on Ubuntu 19.04 libssl error - program wouldn't start (Solved)

I fixed the problem manually, just writing my process down in case anyone else has the same problem.

Steps I took that resulted in the problem:

I downloaded the Ubuntu bit archive from Fritzing website, extracted to my local and ran ./Install and ./Fritzing

The error was “error while loading shared libraries: cannot open shared object file: No such file or directory”

What I expected should have happened instead:

Fritzing normal startup

My version of Fritzing and my operating system:

Fritzing 09b from Fritzing website
Ubuntu Studio 19.04

Please also attach any files that help explaining this problem
Don’t worry I fixed it!

So I got the missing libssl from Debian repo here:

Edit: run dpkg --install filename.deb after downloading it

It was not available through apt on Ubuntu 19.04 - I believe they have replaced this library with a newer one (most likely almost exactly the same thing with a new version number, so you could probably link it up)

If I am incorrect in my assumptions here please correct me. Anyway Fritzing is up and running again for me at least.

I’d say as long as it works your assumptions are fine :slight_smile: . that said it would be interesting if you would try the 0.9.4 pre release available from github, instructions in this thread:

to see if this is already fixed in the pre release version. If it is still a problem, then it should be reported as an issue on github. This is why I have been pushing to restart development, it has been obvious that eventually new versions were going to break Fritzing if we couldn’t get development restarted. Luckily we have gotten development restarted (if slowly so far :slight_smile: ).