1 of 2 nets routed

Hi. Newbie question.

I’m thinking about to produce LED Blinking.

Then I have created using the Breadboard view. However,

I notice a message on the breadboard view’s status bar saying “1 of 2 nets routed - 1 connection still to be routed”.

When I click on the message I get the following message “There are no unrouted connections in this view”.

How do I find the unrouted connection mentioned in the first message?

Is there an unrouted message?

Here is my file:
Sketch .fzz (3.4 KB)


When I loaded your sketch in Fritzing 0.9.3b on Win7 it says breadboard is routing completed which looks to be correct (all the connection points are green). There are unrouted connections in schematic, and in addition the grid was set to an odd value (which may just be me :slight_smile: ). To check in schematic click on view->set grid size and if it is something other than .1 in, click the restore default button (which will set it back to 0.1) and click ok. You then need to move all your parts and connections so they snap to the grid correctly. Normally the “still to be routed” message means you have connections that are still red (even though they look connected if they are red, they are not and you need to move them til they turn green). If that doesn’t fix your problem, post again, because this may also be database corruption on your machine and there is a different cure for that if it is present.


thanks I’ve tried but not fixed.

When I loaded this sketch in Fritzing 0.9.3b on Win10 (fritzing.0.9.3b.64.pc.zip) ,
the breadboard view looks to be collect (all points are green.) , and
schematic view’s probrem is resolved.
breadboard view’s status bar is saying “1 of 2 nets routed - 1 connection still to be routed” yet.

It would be appreciated if you could assist to track down the problem.

It sounds like you have data base corruption. That is usually caused by making a change in one view that conflicts with that in another view. One way to sometimes fix it is to delete all the connections and start again or just start a new sketch and complete on view then move to the next view and wire that according to the rats nest lines. I usually double click on the rats nest line to route it then drag it in to the correct postion before doing the next. Component placement matters (all the pins are numbered) but Fritzing will let you make connections that cause shorts across components and it can’t always recover from that when you delete the bad connection. If it gets bad enough (usually that takes interrupting a parts update though) you need to delete the user directories to clear it but I don’t think you are there yet. Try one or the other of these suggestions and see how it goes.


Looks like a bug in the BB part.
Grab a resistor and lay it on the BB across the 2 black wires that are inserted in the BB and it clears. Also if you move the top black wire 1 position left, so it’s not completing the circuit, it also clears.

I have tried but it result was same.
I tried to delete all connections and start again one of view, then next view connect according to the rats nest lines. and just new sketch too.

I did, and Breadboard view’s status bar saying “Routing completed”.
What do you think we can do to help reduce this problem ?

Sketch(2).fzz (4.0 KB)

My apologies, I was looking at the wrong sketch last night. Indeed your sketch breaks for me as well. It appears to relate to the bendable legs on the led and is likely a bug. While the wire to the cathode of the led says it is connected, for purposes of routing that isn’t correct. If I delete the black wire and connect the cathode of the led directly to the breadboard it appears to work correctly. As does having a second led connected directly to the breadboard like this. Moving the second led up so its cathode doesn’t connect causes the routing error. Yet the rats nest in schematic is showing as correct and will complete routing even when breadboard will not

Sketch_fixed .fzz (3.7 KB)

This sketch is the working version, If you drag the right hand led up so it isn’t connected to the breadboard you will get the 1 more net to route message. A fix is to connect everything to the breadboard that appears to work correctly.


I had checked the LED, and it seamed ok.

I found a part without bendable legs, and it still shows 1 unrouted. Then I move the wire 1 across, and it’s now routed. Kind-of still looks like the BB.
Sketch2 .fzz (11.7 KB)

EDIT - Looks like any part that is floating and connected with a wire to a BB goes crazy. Looks like a combination of things break FZ.

I did that too (it appears to work correctly) .
for example, different parts( three bendable legs type) shows looks like similar problem too.

Untitled Sketch 2-3.fzz (4.7 KB)

In this case, also, do you think how to fix is to connect everything to the breadboard ?
(Should I make to connect sensor to breadboard directly in the BB view? )

I think so too.
Could it be (in the similar way?) we need to connect everything to the breadboard …?

Sketch2-2.fzz (11.4 KB)

Don’t know. I could swear this used to work, but I don’t know that I ever tried a component not on the breadboard. I don’t see why it won’t work as a connector is a connector but it doesn’t . There must be some reasonable explanation that we are missing here. It works if the part is on the breadboard, but I don’t see the difference right now.


I tried every BB, and a floating part with a wire through a BB shows routing errors. So long as 1 leg is in the BB, it’s fine.

It must just be that combination that breaks FZ, because if it is bendable legs its too hard to fix because nearly every part in the CORE bin is bendable.

If we can get development going again we can at least try and fix it (with a lot of other bugs). I’m making progress, I have dev environments running on Wi7 64 and 32 now and am working on Win10 (I don’t expect any problems there) and then I need to write it up so other people can do it as well.


Thank you for the help. I feel relieved now.
Thanks for this tip!
Sorry for my late response.
I appreciate your gesture and support for me.

not a problem, we just go on to other things until someone brings the topic up again. Sometimes it is months between replies in these threads :slight_smile: . We are patient. This is an odd one because I could swear this used to work (and it should work) but I can’ now find an example where it used to work, the common cases (connections between modules) do work and this case may not have come up before. There are rules about connections in breadboard (except for wires which will connect anything to anything, connections must be male to female or female to male for instance). This case however is wires and unless there are rules I don’t know about (always possible because little of this stuff is actually documented except in the source) there is a bug which is worth knowing.