Winfows 10 gui size


#1

Hi,

Sorry for broken english !

I was wondering if there is any gui scale option. Fritzing icon and ect are way to big on my 2 in 1 tablet. I tryed to deactivate the high dpi for old windows aplication under propriety and compatibility but there is no change. Icon , part, text is to big and hard to work on.

Im on windows 10 and the dpi setting for windows and other app are just great. 1920x 1200 pixel screen.

I know there are issue like me with solution but only in linux

Thank you and have a great day


#2

Was wondering if anyone have a solution ?


#3

I can’t really help as I am a Linux user but I would suggest reading https://superuser.com/questions/964731/windows-10-applications-using-wrong-resolution to see if it helps.


#4

Thank you . Im gonna look at that tomorow or before if the temptation to work on fritzing is to big lol . Im in the bed right know !

Have a good night/day


#5

there is a solution in this link but at each restart you need to do it


#6

If it will run from a script you may be able to script it so it auto executes during startup (not that I know how to do that though).

Peter


#7

The reg script option no longuer available since new update :frowning:

It wont start or work at all


#8

One more reason why I stay on Win7 :slight_smile: (not that I have a use for startup scripts). The best I could suggest is ask in one of the Win10 forums as there is a better chance of someone there having a clever work around than here.

Peter


#9

yeah , i’m browsing all the web for that


#10

they should add in parameter the option to scale the ui


#11

Unfortunatly there is no “they”. If we want things we need to be willing to do the work required to make them occur (the source is available, if not easy to even build at this point). That said I don’t see the issue (although I don’t doubt that there is one) the image looks like the normal gui that I see although that may just be scaling being corrected when the image was made.

Peter


#12

Everything is way to big a blurry. Each windows take too much space and text is to big


#13

All I can say is this is really a Windows problem. We know that Windoors is set to display things at 125% and some how you are surprised that everything is too big. We also know that setting the scaling in Windoors to 100% fixes the issue. All of this says Windoors needs fixing not Fritzing. True you could make a program fix the problem that Microsoft created but if you want opensource to fix it I would suggest moving to an Opensource OS. My recommendation would be Ubuntu Gnome (Gnome will be the default desktop in the next official LTS release of Ubuntu as well).


#14

I cant I have a chuwi hi 10 pro tablet. Windoes /android dual boot


#15

I just tried to modify the dll and the exe file but i cant get anything on those only the manifest and the version number . now trying to search in the source code for the file in charge of that and if I find it recompile it with less scaling


#16

You will have to go back through the commits in github to the time when they released 0.9.3b because the current head is full of new bugs that make it unusable.

Also I just did a quick search for windows 10 start an application at a specific resolution and i got this page from Microsoft with all kinds of workarounds and solutions.
https://support.microsoft.com/en-us/help/3025083/windows-scaling-issues-for-high-dpi-devices

Good luck I hope you find a solution that works for you.

Edit: This is the one that stood out to me right away.


#17

That the first thing i tried and… No chanhe at all. Do i have to dellete something or ?. But i read that some aplication is system aware so they read the system dpi a then stick to that. Maybe if i remove everything from fritzing and re instal it under example 125% scaling and after go back to 150 it will work.


#18

How about this solution. Create a new user with a different permanent DPI. Then when you want to use Fritzing log in with that user. If windows is anything like it was way back when I used it you should be able to switch between users on the fly almost as easy as switching between programs.


#19

I FINALLY FOUND A “fix”

Delette everything from fritzing everywhere . restart. intsal fritzing , set dpi to 125 percent start fritzing , change back to 150 , and voila

now I will try to find a workaround to bypass the dpi awareness since it per monitor
but I still dont understand why before uninstal it would not change after dpi change and why when I chek the deactivate dpi scalling in propriety


#20

I would thank you for sending me link that lead to help me find the temporary or maybe my permanant fix .
Yay for open source and this community !

If I find nothing on the dpi awareness maybe I will try to write a script that change the dpi start fritzing wait 2 second and then get to previous dpi