Run inside QTCreator



after a few hours of struggling with just about anything, I’ve managed to build a win32 version with QTCreator.
I’ve used the following run arguments (with my paths) the first time to create the db:
-f “/path/to/fritzing-app/” -parts “/path/to/fritzing-parts/” -db “/path/to/fritzing-parts/parts.db”

and now the db exists. Then I’ve removed the -db argument anc when I run Fritzing I get
the following error inside the “Application output” window:

ASSERT: “!“Tspans should be drawn through QSvgText::draw().”” in file c:\users\qt\work\qt\qtsvg\src\svg\qsvggraphics_p.h, line 218
The program has unexpectedly finished.
The process was ended forcefully.
F:/fritzing-app-master/debug32/Fritzing.exe crashed

Any idea?
Many thanks,
Giovanni Romeo

Search function in the parts view does not work

I will start by saying I am a Linux user and have only built from the command line so I have no experience with QTCreator.

With that said I have a few things to check.

What version of QTCreator are you using? As the build instructions say it was built based on 5.6 so the newer version may not work and it would be worth trying 5.6 if you have used a newer version.

While building on Linux there seems to be a bug where Fritzing will only run properly once after building and after that it complains that it can not find the parts. But if you build a release using the release script it runs perfectly every time. So maybe trying building a release to see if that solves it for you.


Thanks for your reply.
I’ve compiled using QT 5.10, I hope you’re right and the problem is only the QT version.

I’ll try that tomorrow (it’s night here…).
If that’ll work I’ll try to fix an issue I’m having with 0.9.3b (there’s no parts search text field, only the search bin).

Many thanks,
Giovanni Romeo


Great news, I’m able to compile and run it! :grinning:

I’ve set the project to use QT 5.6, did a "fresh "clean & build and now it’s running.

Giovanni Romeo


That is good news! Does search now work for you though? What version of libgit2 are you using, and does it work on the second launch (or do you get the complaint we do on linux that there is a parts update error)?




yes it works on the second lauch.
I can’t remember the libgit2 version I downloaded, since the PC I’ve used to compile is not with me at the moment :slight_smile: I’ll check ASAP.

For info about the search field issue, pls see Search function in the parts view does not work

Many thanks,


Are you using the Visual Studio compiler or mingw? If you are using Visual Studio could you give me the configuration you used please? I’m trying to compile on Win 7 with Visual Studio 2017 and Qt 5.6.2 and it tells me “Could not determine which “make” command to run” which apparently is because the compiler setup is wrong, but I can’t figure out how to set a correct one.




I’ve currently uninstalled QT and Visual Studio because of I’ve almost run out of space on my primary SSD disk, so I can’t help you right now. I remember I was using Visual studio Build Tools 2014 (not the entire Visual Studio thing) or something like that and QT Creator automatically recognized it…
Sorry not being very helpful :frowning:



Not a problem, google is my friend :slight_smile: apparently only the latest Qt versions run with Visual Studio 2017 so I can either build Qt from source to get 5.6 or bite the bullet and try and run Fritzing on Qt 5.10. When I loaded 5.10 Qt appears to have correctly autoconfigured for Visual Studio (I haven’t yet tried a build). As that is the more desirable course going forward, I’m trying that. Assuming I succeed at this I’ll post the procedure for building on Windows as it is a lot more complex than on Linux. So far I’ve manually applied the pull request from someone that fixed the lack of Qtzip in Qt5.10 (manually because I can’t figure out how to get it from github to apply it to my repository because I’m new to github as well). With that in place on Linux Fritzing compiles and starts on 5.10 but the file tool bar is missing so I can’t load a part to see if it actually works. I’m about to start poking at that to see if I can fix it.