Mega2560 R3 Pro Mini


I don’t have the part, nor could find a datasheet, so I asked people to check it before use because I couldn’t verify it.

Mine was 0.100" too wide so I removed it - it doesn’t have the gerb error -, so I left it to someone with an actual board. He added bits I don’t know about, like a 6pin and 8 pin and 6 holes. I can guess the 6 and 8, but I don’t know where the 6 holes go as they don’t look to be on a 0.100" grid. I don’t think I can do anything without the part.

Really those other pin headers shouldn’t be on the PCB because people use it as a template for a shield, and all those extra holes will be drilled in the shield.


The pcb svg has translates (probably moved while grouped). They will usually screw up gerber creation. I’ll remove them and see if that corrects things, if it does can you check the resulting gerber (I don’t have one either)?



I think only the 8 pin header needs to be fixed, the other 6 pin top left and ICSP probably shouldn’t be there because they are just for jumper wires. Then again I don’t have one, so who knows.


Unfortunately the entire part has a translate 90 (all pads) and it looks like its a case of remove it and manually change them back as an ungroup doesn’t fix it.



At least you can run it through the script and fix it for good, if we can get data.

This part has so many different version, because it’s not an official part, and now I see some with a button in place of the 6 pin header.


I found one similar, but I don’t know if it’s right because it’s the CH340 button one and the 8 pin has a hole in it.


OK here is an interrum fix. There are still problems in schecmatic (missing terminalIds and breadboard (missing layerId) but pcb is now generates what appear to be correct gerbers. If you could check it against a real board that would be appreciated. I’ll fix the rest of the problems tomorrow.


replaced by the Mega2560 R3 Pro Mini_fixed.fzpz below



Does your Mega2560 R3 Pro Mini fit on a printout of that footprint, because it’s too narrow compared to the CH340 Mega2560 R3 Pro Mini.

There is something wrong here because my original part is correct to the CH340 Mega2560 R3 Pro Mini drawing I found, and not 0.100" too wide.

EDIT - looks like the blue 16u2 is 36.8mm wide, and the black CH340 is 38mm wide.


Thanks @vanepp, I haven’t checked the updated version yet but will check tonight.
@Old_Grey, I tested the blue one with the ATMETGA16U, not CH340 chip, about 36.8mmx54.2mm and it fits perfectly.


Just wanted to check. I should change mine to black and make a CH340 version because it’s 1 row wider like the CH340’s 68mm.


Please hold off on that til I get this fixed. I’m just cleaning up schematic, but won’t (right now) renumber it so as to not bread current sketches. After that is done I’ll create a new part with pin numbers in sequence (like most Arduinos these are not) and would prefer new parts to be cloned from that so they are correct going forward.



I just found another black one that is 0.100" shorter, with no USB but pins in the PCB.

I think RobotDyn makes the black ones.

The last image has a size comparison.

EDIT - On 2nd thought there is a lot to change in the BB view, and it’s probably not that big of a seller.

EDIT EDIT - Found a better side-by-side.


OK, here is a properly updated version of this part. Fair warning, something I managed to do in the test sketch has managed to offset the silkscreen in the gerbers (for only the test sketch, just a part has the silkscreen correct) which I can’t see any reason for so I think the part works. If I get ambitious (or bored or frustrated with development :slight_smile: ) I may fix this properly and renumber the pins. As it stands the pin numbers are not contiguous and that usually causes problems with the hover on the pin and it displays the description code although in a quick test I can’t see it happening. The down side to making this change (and why I didn’t do it here) is that it will break all existing sketches. This may be good enough, we will see.
Here is the fixed part:

Edit: replaced with a corrected version:
Edit2: add the VTP pin to the 5V bus
Edit3: removed RST from bus as they are all seperate, centered the usb connector and CPU chip in breadboard. Waiting to see if more bus changes are needed.
Edit4: (may be a record :slight_smile: ) Fix one pad in pcb that was off by 0.25mm

Mega2560 R3 Pro Mini_fixed.fzpz (45.8 KB)

removed the test sketch because it is now old …



I can’t get the part imported - part already loaded problem that I can’t seam to fix -, but the 8 pin header and 6 holes are still faulty.
My orig part on the left is fine, so I don’t know what the guy did to damage it.

What’s wrong with the silk, because mine looks ok.


Damn! Last night and earlier this morning the silk looked fine in Fritzing but was offset in gerbv by about 1/2 inch, so the border around the mega pins was in the wrong place. I just reloaded the sketch in gerbv to print out the problem and now its fine! That’s why I didn’t post this last night when I finished it. Don’t know what that is about, but looks like a gerbv issue rather than Fritzing although I’ve never seen it before and can’t reproduce it now. The “part already loaded” error can be fixed by deleting the part in the mine parts bin (I think you have to restart fritzing to get it to actually delete) and if that doesn’t work, either clearing the user directories or remove the fzp file for the mega in My Documents\fritzing\parts\user.



The major problem is the 8pin is still wrong.

Do we need the ICSP header, because that is programming header and not something a shield will need.


I don’t have one, so I’m a poor one to say. The fellow who has one would probably have a better answer than me.



Do you want my original 0.100" part, because it’s not broken like that one.

I hope that guy didn’t use the interim part.


That looks to be the original part (which had translates in pcb), the interrum fix part I posted a couple of days ago works correctly as far as I can see. I just downloaded the one posted and tried it. From gerbv:

I wonder if the svg for the original hasn’t been deleted from your my documents svg directory (because I didn’t change the file names) and you are getting the old version?



That version was in the test sketch. I tried renaming the internal .fzp file of the fixed part but it said part already in bin, so I didn’t test that one.

EDIT - Got the fixed part in and it’s ok now.