Luxeon LED cosmetic grid alignment bug


#1

Steps I took that resulted in the problem:

The Luxeon LED Is not correctly aligned on the ‘standard’ 0.1 grid.

What I expected should have happened instead:

I expected a correct alignment to the default settings. This enables people who just get started with fritzing to make nicer layouts. (And it gives fritzing a better feel, specially for newcomers)

My version of Fritzing and my operating system:

0.9.2b, Ubuntu 64Bit

Please also attach any files that help explaining this problem


#2

Hold the shift key down when dragging the trace… it will snap to horizontal, vertical, or 45 deg… sometimes… kind of weird… you need to play around with it to get the hang of it…


#3

Thanks for that tip.

I used the same part on a 32 bit box, and to my surprise here it is aligned correctly as i expected (both schematic and PCB views are nicely aligned on the grid) <[a typical WTF!? moment]>

So is this some kind of 64/32 bit inconsistency, or did i unwittingly do something else to make this part go ‘off the grid’?
Note that the PCB view is Horizontally and Vertically mis-aligned
And the Schematic view only Vertically…

So is this a real bug or has Schrodingers death cat reincarnated on the quantum flux of a Fritzing particle???


#4

Idiosyncrasies… there is no rime or reason on how they popup on your screen. They seem to come up just any where and rotated in any direction. You just need to drag them around and they will snap into place.


#5

Well then is is an exeption, since on the 64bit box it does snap as shown in the images. This is why i started this thread. For some reason it is misaligned… I’m now on the 32 bit box. I will have a closer look at the 64bit box when I get home tonight.


#6

Have you got your “Align to Grid” checked?


#7

Yes i always have that switched on.
It just doesn’t make sense, why it behaves different on the 64bit machine.

In both cases it’s the same part from the Sparkfun lib. unchanged.


#8

I have played with this for about an hour…
Compared the files from 64bit and 32bit. …no differences
Saved the project on 64bit machine opened in 32bit and the issue still existed now on 32 bit machine. …WTF?

So back to 64bit, played with grid settings etc. no changes…
If I dragged and dropped the Luxeon part on the PCB it just kept itself misaligned even when I turned grid snap off reposition itand turn the snap on , then when drag and drop from the Parts selector is still snapped misaligned!

Then I manually entered the part location in the inspector to 0.000, 0.000
And now all of a sudden it appears to be fixed.

So i hope this story of events can be of any help to anyone for bug hunting.


#9

Turns out that my netbook’s ssd is as corrupt as a politician… And it looks like this is related to this defect