Lots of broken wires in Gerber - too late for 2015's Fab last round?


#1

Hello,

I am really bothered because I wanted to have two circuits made with Fritzing 2015’s last Fab round.

However when looking at the Gerber exports, there are broken wires everywhere.

Looking back at the Fritzing PCB, I notice that those wires appear with green nodes between segments. If one clicks on a breakpoint, all the breakpoints are highlighted, proving they are connected. However if I try to reconnect, the wires got completely mungled!

This mungling issue has been happening with most wires I wanted to change lately, even when they did not exhibit this disconnection issue.

Is there any chance to fix this easily and get those circuits built before 2016 or should I redraw every defective wire (providing there’s no file corruption)? :cry: :cry: :cry:


#2

Looks like we have a BUG, file here. Do you have a backup anywhere that may not exhibit this issue?


#3

I’d agree here and say it’s a bug. I had a similar issue but I never resolved the cause and simply recreated my PCB to resolve the issue.

That being said, Is there not a more efficient way to organize those wires :smile: They’re a bit everywhere! I’ve never seen such spaghetti :smiley:


#4

“That being said, Is there not a more efficient way to organize those wires They’re a bit everywhere! I’ve never seen such spaghetti”

Actually no, it’s not possible because this is for a wearable hence the PCB has to be as small as possible.


#5

This might be an instance of this bug: https://github.com/fritzing/fritzing-app/issues/3115

It has been lurking around for some time and was really hard to catch, but it looks like we have finally fixed it. The patch will be released with the upcoming fritzing 0.9.3.