Importing SVG format to part editor


#1

Hi,
I have been trying to import a SVG file in Part editor Breadboard section on Fritzing. First I have convert a PNG file to SVG file using Inkscape. And I successfully loaded the SVG file into breadboard section. After doing everything when I saved the part. When I want to add that part in beardboard, I didn’t see my part but a Red background. I would appreciate any help on that.


#2

The red background is indicating that you have no connectors defined in the svg. Your easiest solution would likely be to import the png (which I have never found to work that well by the way) in to the original bb svg for the part which will have the correct connectors defined then move the connectors to where they should be in the svg. Pointers to a couple of tutorials on parts making which may also help:

edit: it may be most useful for you to upload the part .fzpz file (7th icon from the left in the reply tool bar) so we can see what is happening / missing.

Peter


#3

Did you add contacts to the converted svg.


#4

Thanks, I did not use contacts to convert, But I am trying to convert over and over again and finally I got something like this (Screen shot), Now I can see my part but it seems a red shade on it.


#5

(from the edit on my previous post in case you missed it).

Peter


#6

You CAN NOT convert a picture and just bring it into FZ Edit. You need to convert it to svg, add nodes to the svg so it has connector pins to assign, and then assign the connector pins in FZ Edit. The video explains it.


#7

Thank you guys, I have done it. And thanks to Old_Grey I did not assigned pins for that part, that’s why fritzing considered the hole picture as a pad. when I assigned pins for that particular one, then the rest of the Image came out from that red shadow.

Ruman