Fritzing interface looking fuzzy - is this normal?


#1

I have just started using fritzing and I have noticed that the parts are fuzzy looking (low resolution). Is this normal?

It’s sort of affecting my productivity (especially with the arduino pin numbers)

I have a surface pro 3 (2160x1440 display) which may be the cause.

Thanks!


#2

I’m using it at 1366 x 768 and no issues.


#3

Hmmm, but your screen height is just over half of mine.


#4

I’m no computer wizz. They just work or not for me. :slight_smile: So unable to advise.


#5

Don’t have a high res screen so can’t help, but there has been discussion of this before in the forum (although as usual I can not find the article I remember). I think there is a qt setting that helps somewhat. Here is one article I found on high res screens:

perhaps someone else has a reference to the other article I remember (or a better search term :slight_smile: ).

Peter


#6

Thanks Peter,

Hmm, in that article it says that its working for some people but not for others. I guess I’m one of the others…

I hope they’ll fix it in an update, but for now, I’ll hang tight and try not to squint too much.


#7

here is the one I was thinking of with a qt level fix:

hopefully this helps (or someone else has a better comment) because development (and thus updates) seems stalled due to lack of developers.

Peter


#8

You could try starting Fritzing with scaling disabled. You will have to go to the fritzing folder in a terminal and invoke fritzing with:

You can also read through this github issue that may have other workarounds since all the scaling issues seem related. https://github.com/fritzing/fritzing-app/issues/3221


#9

There is 2 work around for that. First . right click on the icon . comptability tab. Chek the thing for scaling high dpi box ( sorry for broken english i use french version of windows) and in the list select use application setting ) or disable . then start it as a admin. If that dont work. Before starti g the app. Go in display option of windows . scale back to 100% then start the app and swith to your normal %


#10

Quick screenshot on a 4k monitor next to my 1080p. All seems fine. I’d have to question your hardware…

Everything seems normal to me, all scales to be the same. So you might want to try this on some other hardware.
res settings…