DS1280 module - My first part, please comment


#1

Hello,
This is my first part in Fritzing, so I’m asking for opinions to know if I did it right. Download is after all this text and images.

This is the part I made, the DS1280 in a module that has the 4,7kΩ resistor included.
As you can see, I made 3 variants of the same part, mostly because of the PCB view, so you can have 3, 4 or 7 holes. I don’t know if this procedure is correct. I’d like to hear your feedback.
This are the 3 parts:

UPDATED 28-01-2017.
DOWNLOAD
DS18B20_module_4PIN.fzpz (7.6 KB)
DS18B20_module_3PIN.fzpz (7.6 KB)
DS18B20_module_7PIN.fzpz (8.1 KB)


#2

Here is the 3rd attachment
REMOVED


#3

Just took a quick look at the 1st one(3PIN), and it’s pretty good.
The few things I see, is in SCH view wires join to the middle of pins rather than ends. It’s neater on ends.
The drill holes are a bit weird, you have 3 - 0.030" and a 0.052". I think it’s something in the square pad.


#4

Over all pretty good, but as Old_Grey said, your connectors aren’t right. Using gerbv (from the geda project) to look at the gerbers (created via file->export_>for production->extended gerber to get the gerber files) your square pin on pin1 isn’t correct the circle is bigger than the square and the holes are wrong (.052 on the square and .030 on the others, should be .038 for .25 inch square pins if that’s what you want to use. The 7pin version appears to have the same sequence number as one of the first two as Fritz tells me it is already loaded when I have the 3 and 4 pin ones already loaded. Again as Old_Grey mentioned the connectors in schematic are connecting in the center (which is the default). In theory (and as shown in Old_Grey’s video tutorial on parts creation) you can set this to the compass directions (south in this case I expect) in the new parts editor. Despite his advise and tutorials I haven’t been able to make that work so in the mother of all parts I’m cheating and setting the terminals in the svgs as pins on .02 rectangle and terminals on .01 rectangles which makes for a small red dot but at least works how I want it :-). If you are using Inkscape for your svg editor I can tell you how to change the hole sizes in the svg (and the distorted pad may be because of translates which I now know how to eliminate as well.


#5

Thanks, I’ve worked out the schematic pins to have the joint on the ends. Now I’ll see what happens with the holes as you and vanepp pointed.

I’ll upload again when the changes are made.

Thanks


#6

I decided to discard the square connector and try it in another future part because 2 reasons: 1. I still have to look more on this matter, 2. because I’ve seen that holes for connectors without pin do not have this square shape, instead have the pin head shape around the holes.

I also solved de North-South schematic pins problem.

This would be the actual PCB:

So this is my new version:
REMOVED

Find the 3rd part in the next post.

Thanks for your time and advice


#7

And now I have another question. How do I merge the 3 icons on the part search to one, like in the generic connectors, that you don’t see dozens of combinations but one icon for all.


#8

I was not able to replicate this. My fritzing loads all three parts without problem.


#9

People usually add the square pad to show pin 1, so it’s up to you. You make the square pad the same size as the round pads and use the same stroke. The white in the middle is the size of the hole.

I forgot to mention, try to make all silkscreen black, because in Inspector the icon only shows floating pads with no outline so it’s hard to tell what it is.

In search all similar parts will show, so your 3 will come up, but if you want the Inspector selectable you put them in the same family.
I think it’s Chapter 8


#10

So your FZ doesn’t act like in my video when selecting compass points, that’s weird.


#11

Done :slight_smile:

I can’t make this work, I’ve changed the family name and put all 3 with the same name, but they still appear as 3 icons.

Find the latest files on the first post, I updated them.


#12

If you have 3 different parts in the bin, that’s pretty much how that works.

It’s think it’s only core parts that have 1 icon with all the rest hidden and Inspector selectable.

You should see my diode search, because my 18 made diodes appear.


#13

Ok, then I think I’m done! With all this advices in mind, I’ll continue making my own parts :grin:


#14

Then I must have fumble fingered it and tried to reload one of the ones I had already loaded :slight_smile: . In any case welcome to the club of parts creators (we need more parts!).


#15

Its got to be something that I’m just missing somehow. I was trying to set the direction of a pin to get the connection to the end from the center so I could see how that changed the xml, but I couldn’t get it to actually select the pin in parts editor.


#16

If it doesn’t work like this, that’s weird.