Creating parts with movable schematic elements


#41

It shouldn’t cause more problems as long as you keep a copy of the two directories, my warning was aimed at not having you delete the directories (which is what I often do while making parts with the production directories safely copied elsewhere) and losing your work. Fritzing (at least for me) is perfectly happy to start using the old directories again once I move them back in to place, It keeps most of its user based files in those two directories (there are also some true temp files in local\Temp but I don’t think they are used past the current session and I have never had to delete them although ccleaner will do so.) so it may be worth a try. I just now fired up a Win10 disk on my second machine (I love swappable disk trays :slight_smile: ) to see if I can reproduce the search problems other folks are having on Win10 so I may have more news a bit later. If you can, you may want to export all your created parts as fzpz files and back them up to for instance a thumb drive so you have a copy completely independent of Fritzing (I worked in a University data center for 20+ years and am paranoid about backups because they are out to get me :slight_smile: and I’ve seen a number of bad disasters.

Peter


#42

On this one, have you run a chkdsk on the drive the folder is on? This sort of sounds like a disk error (I know Win7 doesn’t react well to failing sectors)

Peter


#43

Oh, I just hope it doesn’t happen again but I think this was my own fault for renaming the folder.
I reamde the part and remade the circuit. I didn’t have time to try the solutions for my missing search bar yet but I will hopefully get a look at this tomorrow.
Thanks for the help guys.


#44

Just reading what you guys are doing, it doesn’t seam to be an install problem but something that happens with parts.

Can you remember the exact specifics that this happened, and have the file, so I can have a crack at reproducing it. We need it constantly reproducible so the experts know where to look.

I have a spare PC that I can reload OSs anytime if they get destroyed.

EDIT
That’s weird, installing FZ on W10 was ridiculously easy.
There was no hanging, no api-ms-win-crt-runtime-l1-1-0.dll install, and everything had notification boxes to tell you what was happening. This was a fresh install of W10 with a few drivers and the std security it comes with.
What the hell do other people have that is killing FZ?


#45

Same XP here; it was trivial for me. Obviously the hanging is down to git network performance and we have good broadband here. The runtime I am not sure, but possibly down to the specific version of 10 and / or what else is installed. Anniversary edition is known to be a lot more temperamental than the ‘gold’ edition.


#46

I’m using:
Windows 10 Home
Version 10.0.14393 Build 14393

I had the problem with a circuit which I can’t share due to copyright issues with the book I got the circuit from.
Pity too because only 1/4 of the circuit is copyrighted.
I could send it privately to you OG for debugging if that helps…?
But I do still have the corrupted file/directory of the circuit.
The lost project is not important to me now as I recreated it from a save point yesterday and I’m about to start soldering it up now. :smiley:


#47

I’m not smart enough to look at code, I mainly want to break FZ to see if it is reproducible, and see what circumstances make it happen.

I can try to simulate it on std part, because people did lose search without having that particular part. What exactly did you rename.


#48

I started my Win10 and just renamed the folder where I had saved the sketch the previous night.
I then renamed the sketch which was still in the same (newly named) folder.
I had nothing else running at the time. This was the very first thing I done after boot up.
When I tried to open the newly named sketch, it gave me an error message which I did not record.although I believe it may have been this:
.fzz’: zip.open(): %d
I tried renaming the folder and sketch to no avail.
I wonder if my ridiculous folder-naming convention could have played a part…?
"
D:(D) - Projects(D) - Electronics(D) - PCB Projects(0) - Nordl3\Nordl3 - Dual LM Four Quadrant Multiplier
"
Good luck breaking it! :smiley:


#49

The error message looks about right (fritzing has a bug where they forgot to add the errno variable so you get a %d instead of the error number) however assuming this should be read as (broken apart)

drive D
D:

directory
(D) - Projects(D) - Electronics(D) - PCB Projects(0) - Nordl3\

filename
Nordl3 - Dual LM Four Quadrant Multiplier

I don’t see anything wrong with it except the file name is missing the .fzz extension (which I expect is a typo or being supressed as a known prefix as Windows appears to recognize fzz files). However the error message may provide a clue, I’ll try a corrupted zip file and see what happens. Unfortunatly nothing. I renamed a random (non zip) file to your directory and file name in win10 and tried to open it in fritzing and while it came up with the zip open %d error message nothing else happened. Search still works fine and Fritzing didn’t hang.

(edit) if you still have the broken file could you try starting the Frtizing debug consle help->Enable debugging log and try loading your broken file again? I’m interested to see what the debug window has to say about this.

Peter


#50

I enabled debugging and tried to load the file then this was the result:

dbreport:

module Mystery Part - 3 pins:mystery_part_sip_3_100mil obsolete svg C:/fritzing.0.9.3b.64.pc/fritzing-parts/svg/obsolete/icon/mystery_part_icon.svg
module Generic female header - 2 pins:generic_female_pin_header_2_100mil obsolete svg C:/fritzing.0.9.3b.64.pc/fritzing-parts/svg/obsolete/icon/generic_female_header.svg
Setting platform to Arduino
Setting board to Arduino UNO
Setting board to Arduino UNO
Setting port to
Setting platform to Arduino
zip.open(): %d


#51

I used my biggest sketch with around 100 parts, and changing folder and file to D:(D) - Projects(D) - Electronics(D) - PCB Projects(0) - Nordl3\Nordl3 - Dual LM Four Quadrant Multiplier - Win10 removed the \ - did nothing except take the old sketch off the quick start list.


#52

Did you try changing the name of the sketch after the folder-name change?


#53

That’s disappointing :slight_smile: turns out its the same as what it told me when I fed it a non zip file with your directory and file name to Fritzing, so what ever is happening doesn’t seem to be tripping anything in the debug code.

Peter


#54

Made folder in D: FZ test placed file SingleSideSpeedy3.3 Everything Ver2-6.fzz inside.
File/Open, and it’s fine and with search.

Change folder to D(D) - Projects(D) - Electronics(D) - PCB Projects(0) - Nordl3Nordl3 - Dual LM Four Quadrant Multiplier
Reboot. Quick start missing so File/Open, and it’s fine and with search.

Change folder to (D) - Projects(D) - Electronics(D) - PCB Projects(0) - Nordl3Nordl3 - Dual LM Four Quadrant Multiplier
Change file to D(D) - Projects(D) - Electronics(D) - PCB Projects(0) - Nordl3Nordl3 - Dual LM Four Quadrant Multiplier
Reboot. Quick start missing so File/Open, and it’s fine and with search.

Once it’s missing from the quick start it’s always a full manual direct, so it can’t really go wrong.

The name change doesn’t look like the problem, as I remember changing stuff internally and it always tells you something is missing, so I would say something else damaged it. FZ sometimes doesn’t refresh during a session so maybe it got damaged, and only the reboot made it appear.

EDIT
Can’t tell you much more than what the other guys said. File won’t open, and that means it can’t crash FZ.
Does it have a part with movable elements, and are any of the above posted parts one of those.


#55

Sorry guys, I had my soldering boots on yesterday.
It did use 3 of the above multipart files (LM13700, TL074 & TL072) It also used a CA3080 which I made but it also got nuked in the process. The 3080 I shared (above) is a new version I created the following day.
I still have no search bar in Fz but I don’t mind now. I am afraid of corrupting existing circuits with the fix. Thankfully I don’t use the search tab much but if you guys want to use my wonky build for problem finding I’d happily continue to help. Maybe I could send some of you guys a copy of my directory or something? I’m no coder so I will need instruction :smiley:


#56

I think we have two different problems here, at least one person in the other thread on this has fixed his search by applying the latest Win10 update with no changes (at least that he reported) to Fritzing. I’m pretty sure your problem is related to corruption in the temp directories. I have the luxury of multiple machines so I can try things on a non production environment, but that said I’ve never had a problem renaming the two Fritzing directorys to try something and then moving them back, but I also have a complete system backup that I can restore quickly if something does go wrong. As noted earlier it is also a good bet to export your created parts and save the resulting part file and all your sketch files on other media to guard against a disk failure.

Peter


#57

I never did manage to get that search bar working again… Ah well. a reason to make more parts… :smiley:
CD40106.fzpz (9.3 KB)
CD40106 Hex Inverting Schmitt Trigger


#58

NE570.fzpz (10.8 KB)
NE570 Compander


#59

Cool Audio V2164 Quad Voltage Controlled Amplifier
V2164.fzpz (6.9 KB)

A clone of the Analog Devices SSM2164


#60

2N3819 JFET VHF/UHF Amplifier
2N3819.fzpz (5.5 KB)