Create a no connector part in PCB


#1

It’s a part that you can mount on a PCB, but because it’s a plug connect it doesn’t need PCB connectors.

Does anyone know how to make a part with connectors in BB and SCH, but none in PCB.

The red bar is a bit annoying.


#2

There is a way and you can do that… but normally you just slide the off the PCB and don’t use it, and if you want you can hide the ratsnest layer.


#3

It can kind-of be PCB mounted, with a lot of trouble, it’s that the red rectangle looks weird.

I was thinking about making hidden connects or just use 3 of the mounting holes to disguise it, but if there is a better way.


#4

The red rectangle is caused from unassigned pins… Pins this are in you .fzp but not in you .svg.


#5

Yes. The part doesn’t have contacts in PCB view but has them in the others, so there is nothing to assign in PCB view.


#6

Use the hybrid option… add hybrid=‘yes’ to the copper0 and copper1 elements as seen below.

<connector id='connector98' type='female' name='5V@1'>
<description>5V@1</description>
    <views>
    <breadboardView>
    <p layer='breadboard' svgId='connector98pin' />
    </breadboardView>
    <schematicView>
    <p layer='schematic' svgId='connector98pin' terminalId='connector98terminal' hybrid='yes' />
    </schematicView>
    <pcbView>
    <p layer='copper0' svgId='connector98pad' hybrid='yes' />
    <p layer='copper1' svgId='connector98pad' hybrid='yes' />
        </pcbView>
    </views>

#7

Does that mean you have to have contacts in PCB, because I deleted them.


#8

No, leave the PCB as is… The hybrid if for when you leave out the contacts but don’t want the big red square. The .fzp thinks the contacts are there when they are not… If you leave the contacts in, they will appear but won’t be linked. Hybrid is really not a good name… it is kind of confusing.


Bug in Updating SVG image of a part in Part Editor
#9

hybrid=“yes” for each connector in PCB view, working.